Closed Bug 1549023 Opened 3 years ago Closed 3 years ago

All extensions are uninstalled.

Categories

(Toolkit :: Add-ons Manager, defect)

66 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1548973

People

(Reporter: u186330, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.108 Safari/537.36

Steps to reproduce:

This is different, but probably related to, 1548973.

  1. Experienced 1548973.
  2. Switched to Nightly.
  3. Re-enabled extensions by toggling xpinstall.signatures.required. They worked.
  4. Switched between release and nightly a few times.

Note I cannot really reproduce this, it was a one time event.

Actual results:

All extensions spontaneously uninstalled in all channels. I was shown several "Uninstalling extension, thanks for using" pages.

I can now re-install extensions one by one in the nightly channel but not in the release channel.

Expected results:

1548973 should not have happened in the first place.

Once it has happened, the extensions should have been kept disabled until the fix is released, and not have been uninstalled.

Firefox developers are aware of the situation with AddOns and are working the problem. This is being tracked in bug #1548973.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Restrict Comments: true
Duplicate of bug: armagadd-on-2.0
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.