Closed Bug 1549049 Opened 6 months ago Closed Last month

cannot view last sync time

Categories

(Firefox :: Sync, defect, P2)

68 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox67 --- unaffected
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: tortino, Assigned: eoger)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [fxa])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36

Steps to reproduce:

on nightly build, after recent changes, I cannot see anymore the tooltip with the time of last sync. please readd the tooltip or a label with last successful sync time.
thanks.

Thanks for the report for completeness, could you please be more specific about where you are expecting to see the tooltip, perhaps by sharing a screenshot?

IIRC one place this it used to appear was when hovering over the row for your Firefox Account in the hamburger menu. Vijay, was this changes as part of the recent work on the FxA toolbar icon?

Flags: needinfo?(vbudhram)

I'm fairly sure this is a regression from bug 1542334.

https://searchfox.org/mozilla-central/rev/b2015fdd464f598d645342614593d4ebda922d95/browser/base/content/browser-sync.js#974 should also be setting the attribute on 'PanelUI-fxa-menu-syncnow-button' (although it could also be argued it might as well be also be on 'appMenu-fxa-label' (ie, the item that remains on the top-level menu and opens the sub-menu).

Regressed by: 1542334

It was a design decision to remove the tooltip from the top level app menu because the user could not manually initiate sync there. However, I think it is reasonable to show it somewhere, possible the submenu button Sync Now? rfelley thoughts?

Flags: needinfo?(vbudhram) → needinfo?(rfeeley)

Definitely put it on the Sync Now in the menu.

Today the toolbar icon says "Firefox Account" no matter the state of the account.

This makes sense when the user is not signed in.

Perhaps when they sign in we can repeat the last sync time there too.

Objections?

Flags: needinfo?(rfeeley)

Today the toolbar icon says "Firefox Account" no matter the state of the account.
Perhaps when they sign in we can repeat the last sync time there too.

Alternately, some sort of "Signed in as X" tooltip might be appropriate in this case.

Agreed! Exactly that: Signed in as user@example.com.

We avoid using display name, even if it's available, because it can be anything, even obama@whitehouse.gov

The priority flag is not set for this bug.
:markh, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(markh)

Vijay, I'm per-emptively assigning this to you, I hope that's OK.

Assignee: nobody → vbudhram
Flags: needinfo?(markh)
Priority: -- → P2
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Duplicate of this bug: 1565481
Whiteboard: [fxa]
Assignee: vbudhram → eoger
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4695136f7e82
Unify Sync Now buttons logic. r=markh,fluent-reviewers,flod

I can't NI? Zibi till they're back from PTO, but they need to have a look before we can re-land this since we add sync.ftl to browser.xhtml.

Flags: needinfo?(eoger)

Actually data-lazy-l10n-id should do the trick.

Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12ff69a8f360
Unify Sync Now buttons logic. r=markh,fluent-reviewers,flod

Can you file a follow-up about the assertion failure? It looks dodgy - we're ignoring a failure somewhere, we should either be explicit about it or handle it properly (but also, what's failing and why?).

Flags: needinfo?(eoger)

Filed bug 1588163.

Flags: needinfo?(eoger)
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Regressions: 1588793
You need to log in before you can comment on or make changes to this bug.