Closed Bug 1549106 Opened 3 years ago Closed 3 years ago

Linux and Windows builds broken, likely due to issues with quitter extension

Categories

(Firefox Build System :: Toolchains, defect, P1)

defect

Tracking

(firefox-esr60 verified, firefox66 verified, firefox67 verified, firefox68 unaffected)

RESOLVED DUPLICATE of bug 1549061
Tracking Status
firefox-esr60 --- verified
firefox66 --- verified
firefox67 --- verified
firefox68 --- unaffected

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: dogfood, Whiteboard: cert2019)

Linux builds are failing on trees where signatures are verified (mozilla-release, mozilla-esr60, mozilla-beta) and it blocks the release of the builds with the fix for the expired intermediate certificate for the add-ons.

https://treeherder.mozilla.org/#/jobs?repo=mozilla-release&selectedJob=244673655&revision=94eb3f14832dfc714f8bc4044eee043ce61c0299

This looks very similar to cases where the interaction between the profile server and the quitter extension broke, see e.g. bug 1523750 and bug 1448070.

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=244673655&repo=mozilla-release

[task 2019-05-04T19:24:56.201Z] 19:24:56 INFO - make[1]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2019-05-04T20:04:56.241Z] 20:04:56 INFO - Automation Error: mozprocess timed out after 2400 seconds running ['/usr/bin/python2.7', 'mach', '--log-no-times', 'build', '-v']

Next line in the log before the hang should be: JARLOG_FILE=jarlog/en-US.log /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python /builds/worker/workspace/build/src/build/pgo/profileserver.py

Flags: needinfo?(kmaglione+bmo)

Also affecting Windows.

Summary: Linux builds broken, likely due to issues with quitter extension → Linux and Windows builds broken, likely due to issues with quitter extension

Shouldn't this be P1 priority?

Flags: needinfo?(aryx.bugmail)
Flags: needinfo?(aryx.bugmail)
Priority: -- → P1

Fixed by bug 1549061.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1549061
You need to log in before you can comment on or make changes to this bug.