If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla doesn't redraw invalidated window | window not invalidated properly.

VERIFIED FIXED in mozilla1.3alpha

Status

()

Core
CSS Parsing and Computation
P2
major
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: dylang, Assigned: dbaron)

Tracking

({testcase})

Trunk
mozilla1.3alpha
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
I recently updated my changelog page code so that, if you're in a hurry and want
to "preview" alternate themes without changing cookie prefs, you can just select
an alternate stylesheet usinc smart UAs.  I do this by listing each CSS file in
the header with a unique name, so that people using Mozilla can pick different ones.

While changing between styles, specifically one that just used different
background colours to one which uses fixed viewport background images, I found
that Mozilla doesn't properly redraw certain portions of the screen -- either
because it's not invalidating it all, or because it's not redrawing it properly.

Of course, I also noted that it's easier to trigger the reflow bug from bug
146303 (and maybe bug 90270 too) by swithing between the "same" themes (if your
chosen default equals the "new" theme [IE: you set rippled-glass default, then
chose it also]).
(Assignee)

Comment 1

15 years ago
Hmm.  Weird.  I see problems changing from "Manxome" to "default", at least.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

15 years ago
Priority: -- → P2
Target Milestone: --- → Future
(Reporter)

Comment 2

15 years ago
Manxome is the "default" if you don't have a pre-existing cookie :)

You might want to try using the prefs page to set a specific style as default,
then try switching to the "same" one via the menu.  It seems like there are some
bugs in how Mozilla applies stylesheets that are best exposed by re-applying the
stylesheet it's already using (default variable settings?).

Comment 3

15 years ago
adding keyword 'testcase' - provided URL http://inoshiro.com/changelog/

When i change style from 
rippled glass -> Original
rippled glass -> manxome
rippled glass -> default
the screen is not redrawn properly.

reproduced this on 
RedHat Linux 7.2 == 2002-08-19-05 trunk build 
win2000 == 2002-08-16-08-1.0 branch build
win2000 == 2002-08-19-04 trunk build
macos 10.1 == 2002-08-15-05 branch build

changing platform ==> all
Severity: normal → major
Keywords: testcase
OS: Linux → All
Hardware: PC → All

Updated

15 years ago
Severity: major → normal
OS: All → Linux
Hardware: All → PC
(Assignee)

Updated

15 years ago
Severity: normal → major
OS: Linux → All
Hardware: PC → All

Comment 4

15 years ago
http://www.inoshiro.com/ website can not be found anymore.
reporter - please provide reduced testcase.

removing keyword 'testcase' since we have none at present.
Keywords: testcase

Comment 5

15 years ago
reporter - i am unable too reproduce the bug anymore with the original testcase
provided in the url. 

i am resolving this WFM .... if you think otherwise please reopen the bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

15 years ago
I am able to reproduce the bug via:
rippled-glass -> Original
and
rippled-glass -> default page style

in 2002100911.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 7

15 years ago
Right.  I see it too, now, although I didn't the first time I tried.  (I think
the background image may not even have loaded the first time.)
Status: REOPENED → ASSIGNED
It looks like when switching from the background image page (rippled glass) to
one of the others, only the area covered by background image is invalidated.

Comment 9

15 years ago
this is somehow not reproducible each time. I was able to see it only once
during the number of times i tried to switch between style sheets. So, yeah , i
did see it happen once ... i'd say 
(Assignee)

Comment 10

15 years ago
Bug 175131 seems similar.
(Assignee)

Updated

15 years ago
Depends on: 175131
(Assignee)

Comment 11

15 years ago
This seems to be fixed by my patch on bug 175131, although there are still some
problems with the background image not loading / loading slowly some of the time.
Target Milestone: Future → mozilla1.3alpha
(Reporter)

Comment 12

15 years ago
I can test the latest Mozilla against my site from home, where the internal
connection is 100Mbps.  I'll see if it's just a function of the slower outside
connection to my site.
(Reporter)

Comment 13

15 years ago
The only bug I'm seeing with 154921 is that it reflows differently depending on
if it's a fresh view or a refresh.  I can't make it now redraw the background
correctly anymore.

Anyone else care to test it?

Is the no background images loading thing a bug in the cache code?
(Assignee)

Comment 14

15 years ago
Fixed on trunk by checkin of bug 175131, 2002-11-12 03:17:55 PDT.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 15

15 years ago
verified on winXP 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.