Status

()

Core
Layout: View Rendering
P3
normal
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: alanjstr, Assigned: roc)

Tracking

({qawanted})

Trunk
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020625

The redrawing of the buttons on this page causes lots of flickering of the
buttons as they move.  Its also causing flickering as it passes under the layer
at the top.
(Reporter)

Comment 1

16 years ago
It looks like it is repositioning all of the rest of the buttons every time it
moves the one that is supposed to be moving.

Can I get a confirmation that this isn't just on my PC?  It looks fine with IE.

Comment 2

16 years ago
Confirmed on Windows ME using trunk 2002072718.

Looks related to bug 101698, 136549, and 136555.
(Reporter)

Comment 3

16 years ago
I might says dupe bug 136549, but I'd want someone more knowledable to confirm.

Comment 4

15 years ago
confirming - using trunk build 2002121108 on win-xp pro,1.1ghz,512ram,GeForce2 
Go (32MB@32Bit color depth).

Related to this seem bug 170702 and bug 183269
 
Status: UNCONFIRMED → NEW
Component: Image: Layout → Layout
Ever confirmed: true
Summary: Rapid movement of elements causes flickering → [DHTML] Rapid movement of elements causes flickering

Comment 5

15 years ago
Though I have to say that flickering is less comaring to Mozilla1.1b.
Testing Mozilla 1.2.1 it has the same visible flickering as with latest trunk 
build.


Whiteboard: [DUPME]
(Reporter)

Comment 6

15 years ago
I don't think this really matches the other ones.  My site positions via
absolutes.  It might all be related, but none of the descriptions sound similar
enough.  

Updated

15 years ago
Blocks: 21762
Keywords: perf
So.... where are the buttons that are getting repainted?  I don't really see any
buttons on the page....
(Reporter)

Comment 8

15 years ago
I've changed the layout of my homepage since.  The geocities page has some
animation, but now I see a different broken behavior.  I'll check it more
carefully later.

Right now changing tabs after the animation has finished results in the buttons
being in the proper place, except for a hole in the webpage where I can see the
tab I just visited before it.  Sorry I can't do screenshots right now.  

Currently using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b)
Gecko/20030427 Mozilla Firebird/0.6 on this machine.
The remaining problem is a view painting one for the fixed-pos element...
Assignee: pavlov → roc+moz
Component: Layout → Layout: View Rendering
Keywords: perf
OS: Windows 2000 → All
QA Contact: tpreston → ian
Hardware: PC → All
Summary: [DHTML] Rapid movement of elements causes flickering → Incorrect rendering of buttons at top left
Whiteboard: [DUPME]
Priority: -- → P3

Comment 10

15 years ago
this seems to be related to bug 79315
No longer blocks: 21762
(Reporter)

Updated

15 years ago
Summary: Incorrect rendering of buttons at top left → dhtml repaint jittery
Created attachment 188368 [details]
testcase, not minimized

Testcase based from site that shows the jitteriness.
I think I've seen a bug (multiple bugs?) somewhere else about this.
So basically moving visibility:hidden divs shows some jitter?
Keywords: qawanted
Yes, and the use of position:fixed is also an important factor in triggering the
bug.
Right.  That's the widget thing biting us... roc, do we have a bug for having a
single widget per window yet?
I think this is WFM in my debug build that has the "frame display lists" patch in it (bug 317375).
Depends on: 317375
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012614

WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.