Closed Bug 1549362 Opened 7 months ago Closed 7 months ago

Nightlies are not rendering any pages / IndexedDB errors

Categories

(Core :: Storage: localStorage & sessionStorage, defect, blocker)

defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 blocking verified

People

(Reporter: gcp, Unassigned)

References

(Regression)

Details

(Keywords: dogfood, regression)

Current Nightly on Linux. When starting with an existing profile, no pages are loading.

Similar reports coming in from Windows, IndexedDB errors visible in console.

Summary: Nightlies are not rendering any pages → Nightlies are not rendering any pages / IndexedDB errors
Flags: needinfo?(jvarga)
Summary: Nightlies are not rendering any pages / IndexedDB errors → [nightly updates disabled] Nightlies are not rendering any pages / IndexedDB errors

Doesn't reproduce with a clean profile for me, but does with a dirty one. Debug builds have a lot of warnings like this:

0:51.49 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 380
0:51.49 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 570
0:51.49 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 7006
0:51.49 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 7361
0:51.49 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 6468
0:51.49 INFO: [Child 15584, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/LSObject.cpp, line 823
0:51.49 INFO: [Child 15584, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/LSObject.cpp, line 542
0:51.49 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 380
0:51.50 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 570
0:51.50 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 7006
0:51.50 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 7361
0:51.50 INFO: [Parent 9252, QuotaManager IO] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/ActorsParent.cpp, line 6468
0:51.50 INFO: [Child 15584, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/LSObject.cpp, line 823
0:51.51 INFO: [Child 15584, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/localstorage/LSObject.cpp, line 542

Unsurprisingly things go back to working for me with dom.storage.next_gen=false.

Regressed by: 1540402

We should figure out which specific recent lsng change (the compression? the utf8 change?) caused this.

I know exactly what the problem is, but I had an appointment so I told sheriffs to back it out.
Working on a fix now.

Flags: needinfo?(jvarga)

Now that the re-spin appears to be completed are updates still 'disabled' ? Updater says 'up to date'
Nevermind - just got the re-spin update.

Yes, respins are finished and updates are un-frozen. Users should be getting 20190506130308 now.

Jan is going to fix this in the regressing bug, so closing this as fixed by backout.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

I'm confirming that bug is fixed, starting in latest Mozilla Firefox Nightly 68.0a1 (2019-05-06), so I'm marking this bug as VERIFIED.
Thank you very much for instant backout! \o/

Status: RESOLVED → VERIFIED
QA Contact: Virtual
Summary: [nightly updates disabled] Nightlies are not rendering any pages / IndexedDB errors → Nightlies are not rendering any pages / IndexedDB errors
You need to log in before you can comment on or make changes to this bug.