If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

unable to move messages to another folder when offline

VERIFIED FIXED

Status

SeaMonkey
MailNews: Backend
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: blizzard, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.36 KB, patch
Navin Gupta
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
On the 1.0 branch, build from June 29, I'm unable to move messages from my inbox
to an folder while offline.  I'm using 'delete immediately' as my delete model.

Steps to reproduce:

o Go offline.
o Try to move a message from your inbox to another folder.

Note that the message stays in the inbox.
(Assignee)

Comment 1

15 years ago
any idea when this regressed? I haven't checked anything in for a while.
(Assignee)

Comment 2

15 years ago
the message is copied to the other folder, and when you go back online, the
message is deleted from the inbox. So, the problem is that the message is not
deleted from the db when the offline move happens.
(Assignee)

Comment 3

15 years ago
Created attachment 89690 [details] [diff] [review]
proposed fix

fix is to check for this delete model when deciding to delete the source header
of the move. Navin, can I get a review? Chris, I'm guessing that this has been
broken forever, since I don't think anyone has changed this code recently.

Comment 4

15 years ago
Sorry David and Chris,
I just missed this,my bad. The only bugs I found on 'remove immediately'
are deleting while offline (bug 97310). Nothing on moving mesgs with that trash 
mode.

Just clarifying for my sake, that when you are offline, if you
move a downloaded/non-downloaded mesg from inbox to another folder
the mesg is 'moved(copied)' to the new folder. I can go the 
folder and see the newly moved mesg and read it (if it was
a downloaded mesg)

The bug is that when you move it, it doesn't immediately dissapear 
from the inbox like it should.
You have to go online to see the mesg dissapear from the inbox.

Tried other 2 trash modes (move to trash,mark as deleted) and
they behave correctly when moving a mesg from inbox to another folder.

Using 6-27 branch on NT 4.0.


Comment 5

15 years ago
Comment on attachment 89690 [details] [diff] [review]
proposed fix

r=naving
Attachment #89690 - Flags: review+
Comment on attachment 89690 [details] [diff] [review]
proposed fix

sr=sspitzer
Attachment #89690 - Flags: superreview+
(Assignee)

Comment 7

15 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
Using commercial trunk
2002-09-19-08-trunk/ NT 4.0
2002-09-20-08-trunk/ Mac 10.1.5, mac 9.2.2
2002-09-20-08-trunk/ linux 2.2, red hat 7.0

In "remove immediately" trash mode,
I was able to move downloaded mesgs, while offline,
from my inbox to a subfolder. The mesgs 'dissapeared'
immediately from the inbox and appeared in the subfolder.
Went back online and mesgs that were moved, were still 
in it's new folder.

marking verfied.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.