Closed Bug 1549669 Opened 1 year ago Closed 1 year ago

Handle --disable-e10s to avoid causing fennec tests to fail

Categories

(Testing :: Raptor, defect, P1)

Version 3
defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: alexandrui, Assigned: alexandrui, Mentored)

References

(Regression)

Details

Attachments

(1 file)

Bug 1541527 switched the default from -e10s to --disable-e10s causing fennec tests to fail.

No longer blocks: 1541527
Regressed by: 1541527
Attachment #9063157 - Attachment description: Bug 1543369 Raptor cold page-load tests on Firefox android fennec → Bug 1549669 Handle --disable-e10s to avoid causing fennec tests to fail
Blocks: 1551194
Attachment #9063157 - Attachment description: Bug 1549669 Handle --disable-e10s to avoid causing fennec tests to fail → Bug 1549669 - [raptor] Handle "--disable-e10s" argument to avoid causing fennec tests to fail

Details: We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again. (255, 'applying /tmp/tmpgJX6cl\npatching file testing/raptor/raptor/raptor.py\nHunk #3 FAILED at 903\n1 out of 3 hunks FAILED -- saving rejects to file testing/raptor/raptor/raptor.py.rej\nabort: patch failed to apply', '')

Flags: needinfo?(alexandru.ionescu)

What in the earth is this...

Flags: needinfo?(alexandru.ionescu)

It says that there is a merge conflict at line 903 of raptor.py. Given the hg log this is due to the landing of bug 1549948.

This patch conflicts with bebe's patch already landed so I aded him as reviewer also.
Try build:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=93c3f1b7ff490bd4d697455a02d86a1338c6d711

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7abc1485ca90
[raptor] Handle "--disable-e10s" argument to avoid causing fennec tests to fail r=perftest-reviewers,whimboo,ahal,rwood
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.