Closed Bug 1549688 Opened 7 months ago Closed 7 months ago

Can't remove bookmarks over urlbar if browser.newtabpage.activity-stream.feeds.asrouterfeed; false

Categories

(Firefox :: New Tab Page, defect, P1)

68 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- verified

People

(Reporter: svanderger, Assigned: andreio)

References

(Regression)

Details

(Keywords: github-merged, regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  1. Create new profile.
  2. Set browser.newtabpage.activity-stream.feeds.asrouterfeed; false on about:config page.
  3. Open any bookmark and click on star in urlbar.

Actual results:

TypeError: this._handleMessageRequest is not a functionBookmarkPanelHub.jsm:63:33

Regressed by: 1543121
Status: UNCONFIRMED → NEW
Component: Untriaged → Activity Streams: Newtab
Ever confirmed: true
Keywords: regression
Assignee: nobody → andrei.br92
Iteration: --- → 68.4 - Apr 29 - May 12
Priority: -- → P3
Keywords: github-merged
Blocks: 1552599

This bug appears to cause other breakages (e.g. unable to move bookmarks) in the bookmarks functionality as well.

As an example of being unable to move bookmartks with this parameter set to false:

  • Go to any web page
  • Bookmark it

Expected results:

  • You should get a popup asking where to store the bookmark, what to call it etc.
  • Change details and needed and select 'Done'
  • You can then go into the library and move the bookmark to another folder, if required

Actual results:

  • There is no popup and the bookmark gets placed in the 'Other Bookmarks' folder
  • If you go to the library to try and move the bookmark to the correct folder, you are not able to do so until after you have restarted the browser.
Status: NEW → RESOLVED
Closed: 7 months ago
Priority: P3 → P1
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I have verified that the issue is no longer reproducible on the latest Firefox Nightly 68.0a1 (Build ID 20190519213707) on Windows 10, macOS 10.14, and Arch Linux 4.14.3.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.