Closed Bug 1549699 Opened 7 months ago Closed 7 months ago

Restore previous behaviour for audio devices on Windows and Android

Categories

(Core :: WebRTC: Audio/Video, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: padenot, Assigned: padenot)

References

Details

Attachments

(2 files)

It's not ready. I have fixes but it's too big, I'm going to land a partial backout now.

Blocks: 1546237

This is more related to telephony than anything else, and are more suited to
real telephony app.

Pushed by padenot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90cb2313723f
Don't use communication mode and speakerphone mode methods of AudioManager. r=snorp
https://hg.mozilla.org/integration/autoland/rev/19907c1f0f10
Don't use communication devices by default on Windows. r=achronop
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Duplicate of this bug: 1549871
You need to log in before you can comment on or make changes to this bug.