Closed Bug 1549708 Opened 2 years ago Closed 1 year ago

Implement Page.reload's ignoreCache argument

Categories

(Remote Protocol :: CDP: Page, enhancement, P1)

enhancement

Tracking

(firefox72 fixed)

RESOLVED FIXED
Tracking Status
firefox72 --- fixed

People

(Reporter: ochameau, Assigned: ato)

References

(Blocks 1 open bug)

Details

(Whiteboard: [puppeteer-alpha])

Attachments

(2 files)

In bug 1544445 I introduced minimal support for Page.reload.
But Page.reload supports two option arguments, including ignoreCache:
https://chromedevtools.github.io/devtools-protocol/tot/Page#method-reload
Page.reload:
Reloads given page optionally ignoring the cache.

  • ignoreCache
    boolean If true, browser cache is ignored (as if the user pressed Shift+refresh).
Assignee: nobody → ato
Status: NEW → ASSIGNED
Priority: P3 → P1
Depends on: 1563533
Priority: P1 → P2
Depends on: 1589625

Why is this implementation blocked on my patch for bug 1589625?

Flags: needinfo?(ato)

Because it cleans up tabs in a more generic way than could be implemented here.

Flags: needinfo?(ato)

Sure, but what's unclear is why the dependency has been added a day after it actually was been landed. It's basically no blocker given that the feature is already available on central. I will remove the dependency.

No longer depends on: 1589625

Note that Page.reload in Puppeteer is called without any argument. So this is not blocking the alpha release.

Priority: P2 → P1
Whiteboard: [puppeteer-alpha]

Exposes a new nsIDocShell API, isForceReloading, to determine if
the loaded document was force-reloaded or not.

It relies on the underlying behaviour of nsDocShell::IsForceReloading(),
which again relies on nsDocShell::IsForceReloadType(mLoadType).

The getter is used in the remote agent to test that
Page.reload({ignoreCache: true}) works as intended.

Why is this blocking the alpha release? I cannot see that Puppeteer is sending parameters at all. See also my comment 4.

https://github.com/GoogleChrome/puppeteer/blob/master/lib/Page.js#L678-L688

Also Gutenberg doesn't make use of it.

Flags: needinfo?(ato)

I had this patch lying around and I want it to be part of this milestone
so it doesn’t degrade beyond repair.

Flags: needinfo?(ato)
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ece31d77808b
docshell: add nsIDocShell.isForceReloading; r=bzbarsky
https://hg.mozilla.org/integration/autoland/rev/ad943fb7937e
remote: implement Page.reload's ignoreCache argument; r=remote-protocol-reviewers,whimboo
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.