Closed Bug 1549720 Opened 3 years ago Closed 2 years ago

Missing drop markers in MediaPlayback threads if GFX causes frame drops

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1578042

People

(Reporter: whimboo, Unassigned)

Details

I recorded a Gecko profile with the upcoming Raptor Youtube benchmark suite (bug 1548845) which is playing a 1440p60 VP9 video at 2X playback speed:

http://yttest.dev.mozaws.net/2019/main.html?test_type=playbackperf-test&tests=95#1557236658426

Due to known problems (eg. bug 1400787) I expect a lot of dropped frames, which also happen as the test reports. But what makes me wonder is that we do not have any drop markers in the recorded MediaPlayback threads:

profile: https://perfht.ml/2J526O1

As Paul mentioned this is most likely because the problems lay in GFX.

Anyway it would be great to also get drop markers added for those cases.

Priority: -- → P3

Bug 1578042 is adding those markers in the Compositor thread.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1578042
You need to log in before you can comment on or make changes to this bug.