Closed Bug 1549732 Opened 6 months ago Closed 6 months ago

referrer not sent when loading - loadUri(String uri, String referrer, int flags) in Fennec

Categories

(GeckoView :: General, defect, P1)

67 Branch
Unspecified
All
defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: fluffyemily, Assigned: fluffyemily)

References

Details

Attachments

(2 files, 1 obsolete file)

Bug #1545255 fixed this issue for GeckoView but it is still extant in Fennec. This issue is to fix it there too.

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

load a geckoview session with:

geckoSession.loadUri("https://www.whatsmyreferer.com/","www.SomeRef.com",0);

or

geckoSession.loadUri("https://www.whatsmyreferer.com/",Uri.encode("www.SomeRef.com"),0);

Actual results:

Page loads without sent referrer header.

Expected results:

referrer header should have been sent when loading via:

void loadUri(String uri, String referrer, int flags)
Load the given URI with the specified referrer and load type.

void loadUri(Uri uri, Uri referrer, int flags)
Load the given URI with the specified referrer and load type.

Depends on D30524

Pushed by etoop@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f9170a14e636
Use ReferrerInfo instead of ReferrerURI when loading URI r=geckoview-reviewers,snorp
https://hg.mozilla.org/integration/autoland/rev/85c3b0c31659
Add tests for referrer. r=geckoview-reviewers,esawin
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Comment on attachment 9064768 [details]
Bug 1549732 - Update GeckoViewExample to show new DeviceDelegate handling.

Revision D31073 was moved to bug 1549633. Setting attachment 9064768 [details] to obsolete.

Attachment #9064768 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.