Customized headers get misparsed in mozialla-1.1a and stop MailNews

VERIFIED WORKSFORME

Status

MailNews Core
Filters
--
blocker
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Friedrich Lobenstock, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Customized filter headers get misparsed in mozialla-1.1a and stop MailNews
Somehow new customized headers like 
 "AND ("
 " d&"
 "OR ("
appear.

When opening MailNews this is a showstopper if the mail server is an IMAP
server. Because MailNews seems to asks for such header too.

Removing those headers does not help, because after the next restart they
are back again.

Only a downgrade to mozilla-1.0 helps and cleaning the customized filter headers
helps.
(Assignee)

Comment 1

16 years ago
Can you give an example of such a filter or better still attach your rules.dat ?
thx.
(Reporter)

Comment 2

16 years ago
Can I send you the rules file in private?
(Assignee)

Comment 3

16 years ago
yeah, you could do that. 
(Assignee)

Comment 4

16 years ago
worksforme. Did you change anything. I am using latest trunk build which should 
be same as mozilla 1.1a. You can try latest nightly trunk build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
Sorry this week I don't have the nerves and the time to check this. 
Took me already too much time to find out what was the cause and
repairing the settings. Some other projects have deadlines :(

Comment 6

16 years ago
markinng verified worksforme - no recent update from reporter.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

16 years ago
This Bug is now in 1.0.1 !!!

See bug#167944
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.