Preview sometimes not showing when hovering on an object in the editor

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
Last month
18 days ago

People

(Reporter: jarilvalenciano, Assigned: jarilvalenciano)

Tracking

unspecified
Firefox 68

Firefox Tracking Flags

(firefox68 fixed)

Details

(Whiteboard: [good first verify])

Attachments

(2 attachments)

Assignee

Description

Last month

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36

Steps to reproduce:

  1. Open https://nifty-taste.glitch.me/
  2. Set a breakpoint on script.js line 2
  3. Refresh the page to pause on the breakpoint
  4. Hover repeatedly between "a" and "="

Actual results:

The "a" object preview only appears every other time you hover on it from "=".

Expected results:

It should generate a preview for the "a" object every time you hover on it.

Assignee

Comment 1

Last month

The original bug was being caused by a mouseleave from the token and mouseenter into the bracket arrow being triggered immediately after the preview was rendered. This appears less often on longer variable names, but happen all the time for single character variable names.

The problem no longer persists after removing cursor events from the bracket arrow.

Updated

Last month
Assignee: nobody → jarilvalenciano
Component: Untriaged → Debugger
Product: Firefox → DevTools
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

Last month
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/14654d375cc6
Disable cursor events on preview bracket-arrow. r=jlast

Comment 3

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Regressions: 1551631
QA Whiteboard: [good first verify]
Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.