Closed Bug 1549806 Opened 5 months ago Closed 2 months ago

No logins view in the HTML-based password manager

Categories

(Firefox :: about:logins, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox68 --- disabled
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: jaws, Assigned: ntim)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [passwords:management] [skyline] )

Attachments

(3 files, 1 obsolete file)

Attached image 2019-05-07_1527.png
No description provided.
Summary: No logins view → No logins view in the HTML-based password manager
Flags: qe-verify+
Type: defect → enhancement

This view should be shown when there are no saved logins present. Both the LoginList and the selected LoginItem area should have a message describing how to create a login and what this management UI is for.

Work concerning if the user has Master Password enabled but has not authenticated will be tracked in a different bug.

User Story: (updated)
Assignee: nobody → djustice
Status: NEW → ASSIGNED

We will need to have some copy updates before this can land. Trying to track down who the correct person for that is...

Hi Betsy, can you work with Dave to update the copy that we show when a user doesn't have any stored logins. See https://bugzilla.mozilla.org/attachment.cgi?id=9063299 for the proposed text from the UX spec.

"Quick access to your logins" needs to be updated with directions of using the Firefox menu and clicking the "Logins & Passwords" button. Though it seems odd to give someone directions to get to this page once they're already here. The toolbar button that this section refers to has been cut from the MVP.

The section on "Get notified when new breaches occur" has also been cut from the MVP of the management UI.

Flags: needinfo?(bmikel)
Whiteboard: [passwords:management] [skyline]

Updated design and content to align with the desktop implementation of Lockwise (vs. the web extension currently referenced)

InVision: https://mozilla.invisionapp.com/share/EJRHBMEDKF8#/372727457_Presentation_-_Lockwise_Desktop_Home_-_No_Logins_Found

Zeplin: https://zpl.io/VKj5JPW

Flags: needinfo?(bmikel)

The strings:

Looking for your saved logins? Set up sync.

If you saved your logins to Firefox on a different device, here’s how to get them here:

  • Create or sign in to your Firefox account on the device where your logins are saved
  • Make sure you’ve selected the Logins checkbox in Sync Settings
  • Visit Lockwise [frequently asked questions] for more help

NOTE: Link frequently asked questions to: https://lockwise.firefox.com/faq.html

So we no longer want to link to the mobile apps from this page?

Flags: needinfo?(rgaddis)

Well, sort of; we only want to show the promo based on whether or not someone is signed in to Sync or not, which is reflected in the comp above.

I'd argue that we probably don't want to show the promo to users with <1 login as well, but that'd be additional logic, presumably.

Flags: needinfo?(rgaddis)
Assignee: djustice → ntim.bugs
Attachment #9071952 - Attachment is obsolete: true
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/586a0cf2202e
Implement "No logins" screen for about:logins. r=fluent-reviewers,jaws,flod
Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1f571f037efd
Implement "No logins" screen for about:logins. r=fluent-reviewers,jaws,flod
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

I have verified this issue on the latest Nightly 70.0a1 (2019-08-04) (64-bit) on Windows 10, MacOS 10.14 and Ubuntu 18.04.

  • The "No logins" screen is displayed when the about:logins page is accessed without saved logins.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1571463
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.