Closed Bug 1549820 Opened 7 months ago Closed 7 months ago

Typing IP addresses in the URL bar autocompletes improperly

Categories

(Firefox :: Address Bar, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1537640

People

(Reporter: 6mjjmugn96, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Start typing "https://192.168.1.2" into the URL bar

Actual results:

After typing "https://192.", it autocompletes "0.0.0" after my cursor, unhighlighted, so that further typing leaves the "0.0.0" after what I type.

If I shift-right-arrow to highlight the "0.0.0" and continue typing, when the URL bar shows "https://192.168" and then I press ".", it autocompletes to "https://192.0.0.168" and leaves my cursor immediately before the "168".

There are variations of this, depending on how much of the IP address I've typed.

Expected results:

Any autocompletions should happen after the cursor and be highlighted so that further typing will overwrite the autocompletion.

This seems like it might be the same as 1537640, but it seems to be new between 66.0.3 and 66.0.4.

can you still reproduce it in firefox beta?
https://www.mozilla.org/firefox/channel/desktop/

I initially tried to test this by creating a new profile and I wasn't able to reproduce the problem with that blank profile in either version of Firefox. I tried a lot of things to recreate the issue with the blank profile in 66.0.5 and couldn't.

I then tried with my regular profile and can confirm that the beta seems to have solved the problem.

thank you for testing & reporting back. i think for the bug to show up it might need to have some ip addresses in browsing history to autofill. when it's no longer reproducible with your regular profile in beta, then this is like the same issue as bug, which thankfully already received a fix.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1537640
You need to log in before you can comment on or make changes to this bug.