Closed Bug 1549821 Opened 4 months ago Closed 4 months ago

Fix and improve Amazon Search Engine URLs

Categories

(Firefox :: Search, defect, P1)

defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

In writing unit tests for Amazon, I noticed a couple of issues:

  • The German locale de is falling back to the English (en) suggestions URL. It shouldn't have a suggestions URL as Amazon doesn't support it.
  • The br locale is currently unused so we should just remove it.

Anyone know when we're meant to bump the search plugin version numbers? Is it for any change, or don't we need to worry since they're built-in?

Flags: needinfo?(mozilla)
Flags: needinfo?(mdeboer)
Flags: needinfo?(dharvey)

Updated search engines should come to the user with a new buildId causing SearchService to install the engine which should pick up the new data. My understanding is we don't need to update the addon version number but probably a good idea for Shane to confirm.

Flags: needinfo?(mozilla)
Flags: needinfo?(mixedpuppy)
Flags: needinfo?(mdeboer)
Flags: needinfo?(dharvey)

(In reply to Mark Banner (:standard8) from comment #2)

Anyone know when we're meant to bump the search plugin version numbers? Is it for any change, or don't we need to worry since they're built-in?

Any change inside an extension itself should get a version bump regardless, it's a minor thing to do. Right now I think searchservice will ignore that[1] but I'm not absolutely certain (I've been re-examining everything since this weekend).

[1] https://searchfox.org/mozilla-central/rev/99a2a5a955960b0e58ceade1db1f7652d9db4ba1/toolkit/components/search/SearchService.jsm#2036-2042

Flags: needinfo?(mixedpuppy)

Thanks, I've bumped the associated manifests. Thinking about it, it probably won't hurt to be in practice with bumping these, as we may want to be doing that if we end up shipping updates to built-in add-ons.

Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72f13244bf42
Fix a couple of issues with the Amazon search engine urls. r=mkaply
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

rename from browser/components/search/extensions/amazondotcom/_locales/de/messages.json
rename to browser/components/search/extensions/amazon/_locales/de/messages.json

That leaves amazondotcom with a single locale "en". Is that intended?

Flags: needinfo?(standard8)

I left it as it was for now as it doesn't really harm anything in having it separate, and with some of the additional changes we've got coming up, it might turn out it is needed or maybe not.

Flags: needinfo?(standard8)
Regressions: 1552185
Flags: qe-verify+

I managed to reproduce the issue using an older version of Nightly (2019-05-07) on Windows 10 x64.
I retested everything using latest Nightly 69.0a1 and Firefox 68.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64 and I got these results:

  • on DE builds: the list of suggestions are not displayed at all.
  • on BR builds: the search engine for amazon is still present.
    Is this the expected behaviour? Because I am not sure how to test this. Thank you.
Flags: needinfo?(standard8)

(In reply to Oana Botisan, Desktop Release QA from comment #10)

I managed to reproduce the issue using an older version of Nightly (2019-05-07) on Windows 10 x64.
I retested everything using latest Nightly 69.0a1 and Firefox 68.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64 and I got these results:

  • on DE builds: the list of suggestions are not displayed at all.

That's correct. The DE version of amazon doesn't support suggestions.

  • on BR builds: the search engine for amazon is still present.

That's expected, it should point to Amazon.fr. The br locale that was an option within the search engine that wasn't used.

Flags: needinfo?(standard8)

Considering comment 10 and comment 11 I will mark this issue as verified fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Iteration: --- → 68.4 - Apr 29 - May 12
You need to log in before you can comment on or make changes to this bug.