Open Bug 1549899 Opened 9 months ago Updated 5 days ago

Firefox can't update to the latest version due to installer not adding maintenance service registry keys

Categories

(Firefox :: Installer, defect, P3)

66 Branch
x86_64
Windows 10
defect

Tracking

()

UNCONFIRMED

People

(Reporter: Richard, Unassigned)

Details

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Click on the Help->About Firefox menu to check for updates and/or restart Firefox to try and update it.

Actual results:

I get a message saying that "Firefox can't update to the latest version. Download a fresh copy of Firefox and we'll help you to install it."

I download the new version and install it, and all is well until the next update when I have to repeat the manual download and install process.

Expected results:

I use Firefox on multiple PCs and they all update automatically when restarting Firefox after an update is released. But this PC has this particular issue every time there is an update and requires manually downloading and installing Firefox.

I'd like to know why the auto update feature doesn't work on this PC and find a way to resolve it if possible.

The only thing I can think of that's different with this particular Firefox installation from my other PCs is that I use multiple Firefox profiles on this PC.

Component: Untriaged → Application Update
OS: Unspecified → Windows 10
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64

Thanks for the report. It's not immediately clear what's going wrong here, and it would help a lot to get some logs for us to look at. Please do the following steps:

  1. Type about:config in the url bar and press return
  2. Click the "I accept the risk" button if it is displayed
  3. Type devtools.chrome.enabled in the search box
  4. Toggle the value from false to true by either double clicking it or via the context menu.
  5. Open Tools -> Web Developer -> Browser Console
  6. Copy and paste the following into the text box at the bottom:
    var fileLocator = Cc["@mozilla.org/file/directory_service;1"].getService(Ci.nsIProperties); var dir = fileLocator.get("UpdRootD", Ci.nsIFile); dir.reveal();
  7. In the directory that is opened attach the active-update.xml and updates.xml files to this bug
  8. In the updates subdirectory attach the last-update.log and the backup-update.log files if they exist.
  9. In the 0 subdirectory attach the update.log and the update.status files if they exist.

Thanks again.

Flags: needinfo?(Richard)
Priority: -- → P3
Attached file updates.xml
Flags: needinfo?(Richard)
Attached file last-update.log
Attached file backup-update.log

I've attached the requested files. (There was no active-update.xml, update.log, or update.status.)

Great, thanks for the info.

So this is a bit confusing. It looks like this is the error being hit. But when you're running the installer, it should be correcting that error. I don't understand why it isn't.

Just to make sure, can you attach one more log file? It's "C:\Program Files (x86)\Mozilla Maintenance Service\logs\maintenanceservice.log" (the path is always the same, so it's easy to find). Thanks again.

Flags: needinfo?(Richard)
Attached file maintenanceservice.log
Flags: needinfo?(Richard)

FYI I see in maintenanceservice.log it says this registry key doesn't exist "SOFTWARE\Mozilla\MaintenanceService\f9b87e891978e3145f0f8f9953eadc00". I checked in the Registry Editor and although HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\MaintenanceService exists, there is no f9b87e891978e3145f0f8f9953eadc00 key inside it.

Thanks for checking the registry key, that was indeed the next question I was going to ask. I'm confused because the installer should always create that key when it's run with administrator privileges (and I'm assuming it is being run that way because your installation is in Program Files). The name of the key in the log is the correct one, so that's not the issue.

I expect that your problem could be worked around by importing the expected contents of that key, so I'm attaching that here. But I'm not going to close the bug quite yet even if that works because I don't understand why the key doesn't exist and I want to try to think of some ways to diagnose that.

Importing that registry key did the trick. I then restarted Firefox and it successfully updated on it's own. Thank you so much for your help! (I've been dealing with this issue for years--I should have submitted a bug report a long time ago...)

I'm happy to help out if there's anything else I can do to help you troubleshoot the root cause of that key not being installed.

Glad that worked. I don't have any ideas right now, but I'll reply back here if I think of something to help track this down.

Okay, we thought of something. When you have a chance, could you please try this:

  1. Delete the f9b87e891978e3145f0f8f9953eadc00 key.
  2. Leave the registry editor open and pointed to MaintenanceService.
  3. Download a fresh Firefox installer and run it.
  4. Immediately after the installer is done, refresh the registry editor and see if f9b87e891978e3145f0f8f9953eadc00 exists.

We're trying to find out whether the installer is failing to create the key like it's supposed to, or something else on the system is causing it to be removed after the fact.

Thanks.

Flags: needinfo?(Richard)

I tried the above steps, but the installer did not add the missing registry key.

Flags: needinfo?(Richard)
Summary: Firefox can't update to the latest version → Firefox can't update to the latest version due to installer not adding maintenance service registry keys
Component: Application Update → Installer
Product: Toolkit → Firefox
Priority: P3 → --
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.