The tree column picker menu from the Saved Logins dialog box is wrongly displayed if opened twice

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
3 months ago

People

(Reporter: emilghitta, Assigned: bgrins)

Tracking

(Regression, {regression})

68 Branch
mozilla68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 verified)

Details

Attachments

(2 attachments)

Posted image Saved Logins.gif

Affected versions

  • Firefox 68.0a1 (BuildId:20190507214514)

Unaffected versions

  • Firefox 67.0b18 (BuildId:20190506235559)
  • Firefox 66.0.5 (BuildId:20190507012018)
  • Firefox 60.6.1esr (BuildId:20190322020346)

Affected platforms

  • Windows 10 64bit
  • Ubuntu 16.04 32bit
  • macOS 10.12.6

Steps to reproduce

  1. Launch Firefox.
  2. Click the Hamburger menu.
  3. Click the Logins and Passwords button.
  4. Click the tree column picker button.
  5. Close the tree column picker menu.
  6. Click the tree column picker button again.

Expected result

  • The menu is successfully displayed.

Actual result

  • The menu is wrongly displayed after being opened the second time.

Regression range

Additional Information

  • I have attached a screencast for this issue.
  • Please note that this seems to be reproducible with the tree column picker from the Certificate Manager dialog box (People tab) as well. It doesn’t seem reproducible with the tree column picker from the "Your Certificates", "Servers" and "Authorities" tabs.

Hi Brian,

It seems that mozregression pointed out Bug 1500626 for causing this regression.

Can you please take a look?

Thanks!

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(bgrinstead)
Priority: -- → P1

Looks like the children of <menuitem> in the tree col picker are getting [hidden] set on them. Taking a look.

Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)

Just a small update. This seems to be reproducible with the tree column picker from the "People" tab (Certificate Manager dialog box) as well.

Since the menuitem DOM is not anonymous anymore, without scoping the selector
we end up hiding contents of menuitems as well.

Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/633722f0bc3d
Only hide direct children of treecolpicker menupopups r=surkov
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

This issue is verified fixed using Firefox 68.0a1 (BuildId:20190515092556) on Windows 10 64bit, macOS 10.12.6 and Ubuntu 16.04 64bit.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.