Closed Bug 1550165 Opened 6 months ago Closed 3 months ago

Footer advertising links to Lockwise mobile apps

Categories

(Firefox :: about:logins, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 + verified

People

(Reporter: jaws, Assigned: mcrawford)

References

Details

(Whiteboard: [passwords:management] [skyline] )

Attachments

(1 file)

The login manager page should have a footer that has links to install the Lockwise mobile apps.

Flags: qe-verify+
Assignee: nobody → djustice

How should we handle the localizing of the google play and app store icons? We had this as a todo for lockwise, I'll can ping m_and_m and see what the original plan was and report here.

Attachment #9071001 - Attachment description: Bug 1550165 - Footer advertising links to Lockwise mobile apps → Bug 1550165 - Footer advertising links to Lockwise mobile apps. r?jaws
Flags: needinfo?(jaws)

(In reply to Dave Justice [:JSON_voorhees / :meandave] from comment #1)

How should we handle the localizing of the google play and app store icons? We had this as a todo for lockwise, I'll can ping m_and_m and see what the original plan was and report here.

We should use graphics that don't include text. That will be the best approach. Let's exhaust that search before trying to figure out what to do otherwise.

Until we hear back from legal to clear us packaging these graphics, can you include all of the graphics in each locale in your patch, and then add some code to choose the right graphic based on the browser's locale? You can enumerate the array from Services.locale.requestedLocales[1] until you find a match of a graphic that we are shipping. If no match is found then you could use the "en-US" graphics.

[1] https://searchfox.org/mozilla-central/rev/1133b6716d9a8131c09754f3f29288484896b8b6/intl/locale/mozILocaleService.idl#157

Flags: needinfo?(djustice)
Flags: needinfo?(djustice)
Whiteboard: [passwords:management] [skyline]
Assignee: djustice → mcrawford
Depends on: 1568681

[Tracking Requested - why for this release]:

Attachment #9071001 - Attachment description: Bug 1550165 - Footer advertising links to Lockwise mobile apps. r?jaws → Bug 1550165 - Footer advertising links to Lockwise mobile apps. r?mattn
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/fc5ca772497d
Footer advertising links to Lockwise mobile apps. r=fluent-reviewers,Pike,MattN
Backout by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91ae5f60b8c0
Backed out changeset fc5ca772497d for causing build bustages. CLOSED TREE
Flags: needinfo?(djustice)
Keywords: checkin-needed

Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/9a0528095590
Footer advertising links to Lockwise mobile apps. r=fluent-reviewers,Pike,MattN

Keywords: checkin-needed
Depends on: 1574203
Flags: needinfo?(mcrawford)
Keywords: checkin-needed

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/773f75efd745
Footer advertising links to Lockwise mobile apps. r=fluent-reviewers,Pike,MattN

Keywords: checkin-needed
Duplicate of this bug: 1568681
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1574869
Regressions: 1574876

I have verified this issue on the latest Nightly 70.0a1 (2019-08-18) (64-bit) on Windows 10, MacOS 10.14 and Ubuntu 18.04.
- The Mobile Promotion is displayed on the bottom of "about:logins" page.
However, while verifying that the Mobile Promotion is displayed we have encountered the following issues:
- Mobile promotion is displayed even if you are not logged in. Logged bug 1574873.
- Mobile Promotion overlaps with the "Login Item" when resizing the browser. Logged bug 1574883.
Also, it seems that this feature introduced the following regressions:
- All the buttons and fields from the “Login Item” and “Create New Login” mode are no more functional when the Mobile Promotion is displayed. Logged bug 1574869.
- The "Lockwise" favicon is no longer displayed on the "Logins & Passwords" tab. Logged bug 1574876.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

This bug caused the regression below which was not backed out, but fixed by bug 1555894. Does this make sense?
== Change summary for alert #22500 (as of Fri, 16 Aug 2019 15:20:10 GMT) ==

Regressions:

1% installer size osx-shippable opt nightly 79,847,226.33 -> 80,453,554.00

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=22500

Flags: needinfo?(mcrawford)
Flags: needinfo?(mcrawford)
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.