Thread-safe method dispatch

RESOLVED FIXED

Status

Core Graveyard
Java to XPCOM Bridge
P3
enhancement
RESOLVED FIXED
18 years ago
3 years ago

People

(Reporter: Frank Mitchell, Assigned: Igor Kushnirskiy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Since Java is multithreaded, make sure calls from Java to Mozilla are
synchronized on a common lock, or otherwise prevented from accessing
single-threaded code simultaneously from multiple threads.
(Reporter)

Comment 1

18 years ago
Assign to self, until other help emerges.

Comment 2

18 years ago
Frank Mitchell no longer works at Sun and his email is bouncing. Reassigning
his 21 bugs to george for reassignment.
Assignee: frankm → drapeau
Status: ASSIGNED → NEW

Comment 3

18 years ago
Re-assigning to lead engineer of BlackConnect, Igor Kushnirskiy.
Assignee: drapeau → idk
(Assignee)

Comment 4

17 years ago
*** Bug 15504 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

17 years ago
the bug was fixed and integrated while ago

closing as fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.