Closed Bug 1550256 Opened 5 months ago Closed 4 months ago

Thunderbird very slow when lightning addon enabled

Categories

(Calendar :: General, defect)

Lightning 6.2.5
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1509739

People

(Reporter: arnie, Unassigned, NeedInfo)

Details

(Keywords: perf)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36 OPR/58.0.3135.132

Steps to reproduce:

I simply load Thunderbird with lightning enabled. Thunderbird 64-bit version 60.6.1 and Lightning version 6.2.6.1

Actual results:

After a few minutes Thunderbird becomes extremely slow. It can take up to 15 seconds to open an email or to perform any other function on Thunderbird.

If I close Thunderbird it will be normal until after a few minutes when it then gets slow again.

Problem never happens with lightning enabled.

Expected results:

Thunderbird should remain as fast as when I first opened it.

Component: Untriaged → General
Keywords: perf
Product: Thunderbird → Calendar
Version: 60 → unspecified

Another possible dupe of bug 1509739? Arnold, are you running 60.7.0 now or beta? How does it work in Safe Mode?

He mentions version 60

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Version: unspecified → Lightning 6.2.5
Duplicate of bug: 1509739

While in safe mode Thunderbird does not exhibit the problem. The only addon I'm using is lightning calendar. I am running the Walnut2 theme.

So do you guys think this issue is at all sounding like what's happening in bug 1509739 or bug 1522990? The part about disabling Lightning and everything works seems quite similar. The fix seems to be to start use a new profile.

Arnold, is this something you'd be willing to try and confirm as per what is stated in https://bugzilla.mozilla.org/show_bug.cgi?id=1509739#c4 and https://bugzilla.mozilla.org/show_bug.cgi?id=1513202#c6 ?

Flags: needinfo?(arnie)

I believe this bug is a duplicate of Bug 1502923 for which a patch was issued but hold back due to causing a regression in 68.x branch as Lightning code changed a lot in that branch since 67.x.

The current workaround you can try is to make sure that in the Calendar view > Find Event area you choose something like "Currently Selected Day" instead of "All Events" in the selection box prior restarting TB. This would minimise the issue and TB should be working again at a more quicker pace after startup though keep in mind this does not effectively sort the issue, TB would remain unavailable during calendar loading, just minimise it... become usable again more quickly...

Not a solution but may help you to cope with the issue for now.

You need to log in before you can comment on or make changes to this bug.