need a smarter "allow other fonts" preference

VERIFIED DUPLICATE of bug 79074

Status

()

Core
CSS Parsing and Computation
--
enhancement
VERIFIED DUPLICATE of bug 79074
16 years ago
16 years ago

People

(Reporter: dmitry, Assigned: dbaron)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Now, in Preferences / Appearance / Fonts, the "Allow documents to use other
fonts" option disallows all font specifications, including both generic:

font-family: sans-serif;

and specific:

font-family: helvetica;

What would be more useful is the ability to differentiate between these cases,
so the user can disallow specific font settings but still allow the stylesheets
to use generic settings. These generic settings would then resolve into the
specific font families configured by the user on the same preferences page. So,
this option should be broken into two, one for generic font types and the other
for specific font families.  

Given that most people provide both alternatives in their stylesheets, as in

font-family: helvetica, sans-serif;

leaving only generic settings enabled would result in most pages looking
acceptably close to the page author's intention, at the same time protecting the
user from rigid no-fallback specifications that refer to fonts which are not
well suited for browser display.

And by the way, to be consistent, the settings for everything except serif and
monospace should be grayed on that page if the generic font types (or all
document font settings, as now) are disallowed because they would never have any
effect anyway.

Comment 1

16 years ago
.
Assignee: ben → dbaron
Component: Preferences → Style System
QA Contact: sairuh → ian
(Assignee)

Comment 2

16 years ago
See also bug 105297.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
What about implementing this via bug 56441 ("Need font banning") ? I consider to
implement that RFE via accept/deny regex filters... any suggestions ?
(Assignee)

Comment 4

16 years ago
This is totally and completely unrelated.

Comment 5

16 years ago
David Baron wrote:
> This is totally and completely unrelated.

Really ?

See comment #0:
-- snip --
What would be more useful is the ability to differentiate between these cases,
so the user can disallow specific font settings but still allow the stylesheets
to use generic settings.
-- snip --
My idea was to filter the CSS font spec and allow or disallow fonts per regex
filters...

... or would a regex-based mapping system (e.g. ".*times.*" --> "new times")
better here ?
(Assignee)

Comment 6

16 years ago
This bug is specifically about allowing generic fonts but not anything else.
(Assignee)

Comment 7

16 years ago
Anyway, this is a duplicate.  Please do NOT carry the regex discussion over.

*** This bug has been marked as a duplicate of 79074 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.