Intermittent TEST-UNEXPECTED-TIMEOUT | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | rejectionhandled is dispatched from a queued task, and not immediately - Test timed out

RESOLVED INVALID

Status

()

defect
P2
normal
RESOLVED INVALID
3 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell needswork:owner])

Filed by: opoprus [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=245437472&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/KIRCXfZ4RhuiWoz7UWto8w/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-08T22:51:23.356Z] 22:51:23 INFO - TEST-START | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html
[task 2019-05-08T22:51:23.359Z] 22:51:23 INFO - Closing window 80
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO -
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | delayed handling: postMessageTask before promise creation/rejection, plus many promise microtasks, is not too late to attach a rejection handler
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | delayed handling: postMessageTask after promise creation/rejection, plus many promise microtasks, is not too late to attach a rejection handler
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | delayed handling: a nested-task delay before attaching a handler causes unhandledrejection
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | delayed handling: a nested-postMessageTask after promise creation/rejection, plus promise microtasks, is too late to attach a rejection handler
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | delayed handling: a nested-postMessageTask before promise creation/rejection, plus many promise microtasks, is too late to attach a rejection handler
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | delayed handling: a nested-postMessageTask after promise creation/rejection, plus many promise microtasks, is too late to attach a rejection handler
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | delayed handling: delaying handling by setTimeout(,10) will cause both events to fire
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | mutationObserverMicrotask vs. postMessageTask ordering is not disturbed inside unhandledrejection events
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | postMessageTask ordering vs. the task queued for unhandled rejection notification (1)
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-PASS | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | postMessageTask ordering vs. the task queued for unhandled rejection notification (2)
[task 2019-05-08T22:52:03.455Z] 22:52:03 INFO - TEST-UNEXPECTED-TIMEOUT | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | rejectionhandled is dispatched from a queued task, and not immediately - Test timed out
[task 2019-05-08T22:52:03.664Z] 22:52:03 INFO - TEST-UNEXPECTED-TIMEOUT | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.html | expected OK
[task 2019-05-08T22:52:03.664Z] 22:52:03 INFO - TEST-INFO took 40307ms
[task 2019-05-08T22:52:04.292Z] 22:52:04 INFO - Closing logging queue
[task 2019-05-08T22:52:04.292Z] 22:52:04 INFO - queue closed
[task 2019-05-08T22:52:04.309Z] 22:52:04 INFO - Setting up ssl
[task 2019-05-08T22:52:04.316Z] 22:52:04 INFO - certutil |
[task 2019-05-08T22:52:04.332Z] 22:52:04 INFO - certutil |
[task 2019-05-08T22:52:04.347Z] 22:52:04 INFO - certutil |
[task 2019-05-08T22:52:04.347Z] 22:52:04 INFO - Certificate Nickname Trust Attributes
[task 2019-05-08T22:52:04.347Z] 22:52:04 INFO - SSL,S/MIME,JAR/XPI
[task 2019-05-08T22:52:04.347Z] 22:52:04 INFO -
[task 2019-05-08T22:52:04.347Z] 22:52:04 INFO - web-platform-tests CT,,
[task 2019-05-08T22:52:04.347Z] 22:52:04 INFO -
[task 2019-05-08T22:52:06.039Z] 22:52:06 INFO - adb Granting important runtime permissions to org.mozilla.fennec_aurora
[task 2019-05-08T22:52:07.272Z] 22:52:07 INFO - adb launch_application: am start -W -n org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp -a android.intent.action.VIEW --es env9 MOZ_PROCESS_LOG=/tmp/tmpdI_LvQpidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env10 R_LOG_LEVEL=6
[task 2019-05-08T22:52:08.603Z] 22:52:08 INFO - Starting runner
[task 2019-05-08T22:52:09.443Z] 22:52:09 INFO - TEST-START | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.serviceworker.https.html
[task 2019-05-08T22:52:09.459Z] 22:52:09 INFO - Setting pref dom.promise_rejection_events.enabled (true)
[task 2019-05-08T22:52:10.124Z] 22:52:10 INFO - ..................................
[task 2019-05-08T22:52:10.125Z] 22:52:10 INFO - TEST-OK | /html/webappapis/scripting/processing-model-2/unhandled-promise-rejections/promise-rejection-events.serviceworker.https.html | took 679ms

Priority: -- → P2
Blocks: 1525554

bug 1558851 fixes this by changing the metadata that expects this test get timeout. However, we get an opposite intermittent result, bug 1560511. Let close this since we won't get intermittent timeout anymore, and keep tracking of this in bug 1560511.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → INVALID
See Also: → 1560511
You need to log in before you can comment on or make changes to this bug.