mozilla crashes on startup after loading ttf (truetype/freetype, font)

RESOLVED DUPLICATE of bug 155175

Status

()

Core
Internationalization
--
critical
RESOLVED DUPLICATE of bug 155175
16 years ago
16 years ago

People

(Reporter: Ray Tsang, Assigned: Matti)

Tracking

({crash, intl})

Trunk
Other
Linux
crash, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Mozilla worked wonderfully until I installed a few hundred TrueType fonts.  
There are currently ~540 ttf files in the font dir. Mozilla crashed after  
loading about half of them.
(Reporter)

Comment 1

16 years ago
Created attachment 89703 [details]
Mozilla loading fonts in truetype/ dir

Mozilla terminated after DUET____.ttf, with no error description.
(Reporter)

Comment 2

16 years ago
Created attachment 89705 [details]
My /usr/X11R6/lib/X11/fonts/truetype/ content
a talkback incident ID or a stack trace would be nice here... ;)
Mail from Ray:

  How can i obtain that info? it does not appear that talkback is loaded at
  the point that it terminates :/

ccing bstell, who may have an idea of how to approach this...

Comment 5

16 years ago
Could you set the environment variable NS_FONT_DEBUG=FFF, capture moz's 
output when starting, and attach it to this bug?

Thanks
(Reporter)

Comment 6

16 years ago
Created attachment 89887 [details]
Mozilla output with NS_FONT_DEBUG=FFF

This is done following bstell's instruction.

Comment 7

16 years ago
This looks similar to bug 155175.  Can someone apply that patch and see if it
helps (or retest this after that patch is in)?
(Reporter)

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 155175 ***

*** This bug has been marked as a duplicate of 155175 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: Browser-General → Internationalization
Keywords: crash, intl
Resolution: --- → DUPLICATE
Summary: mozilla crashes on startup after loading ttf → mozilla crashes on startup after loading ttf (truetype/freetype, font)
(Reporter)

Comment 9

16 years ago
The patch for bug 155175 worked for me.  Thank you. 
 
However, the font loading process appears to be somewhat time consuming, for 
it seems to happen for every page load?  Regardless, I will solve that problem 
by moving the fonts away from mozilla for now. :p 

Comment 10

16 years ago
> the font loading process appears to be somewhat time consuming, for 
> it seems to happen for every page load?

It this correct? If so it is a serious problem and a bug should definitely be
opened.
(Reporter)

Comment 11

16 years ago
my bad. the font reloading problem seems to be caused by galeon.  mozilla by
itself is behaving efficiently.  thank you.
You need to log in before you can comment on or make changes to this bug.