Closed Bug 1550454 Opened 5 years ago Closed 2 years ago

Reddit forums with a lot of video content are reloaded upon scrolling - poor performance

Categories

(Core :: Audio/Video: Playback, defect, P3)

ARM64
Windows 10
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- fix-optional

People

(Reporter: tbabos, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Affected versions
Nightly aarch64 68.0a1 2019-05-07
Beta aarch64 v67.0b19; Build ID: 20190507205628
Release aarch64 66.0.5; Build ID: 20190507012018

Affected platforms
ARM64 - Windows 10.

Steps to reproduce

  • Launch Firefox
  • Go to a subreddit with a lot of video content, such as: https://www.reddit.com/r/Overwatch/
  • Scroll down a while to load the videos and suddenly scroll back up

Expected result
The previously loaded content should remain displayed.

Actual Result
Some of the videos and Site UI will need to be re-rendered: https://streamable.com/0lhn6

Note

  • On Release this issue is way more visible as it will cause the system crash.
  • Nightly and Beta will not crash but mostly all the previously loaded content will be re-loaded again.
  • The content is a bit loaded way more slowly due to video recording, but it can be reproduced.

Regression-Range
Wondering if it could be due to the fix of green frames and system crashes solved in Bug 1548410

Priority: -- → P3
Regressed by: 1548410

Marking as P2 as the bugs marked as duplicates were P2, feel free to reprioritize if you think this is actually a P3

Flags: needinfo?(jyavenard)

Suspending the videos when they are no longer visible is done by design as it allows to save on memory resources.

Right now performance appears poor on arm64 for windows because we had to blacklist the video drivers version 23.18.9310.0 as they were too crashy

There's not much we can do here until Qualcomm has rolled out the driver updates. They are already available in Windows Preview.

Flags: needinfo?(jyavenard)

Happy to take a patch, but since this is already triaged by devs, set to P3. and not a high impact issue, I'm setting it fix-optional to remove it from weekly regression triage.

This is still reproducible on latest Nightly 71.0a1 (2019-09-11) (64-bit) on the same Lenovo Yoga laptop with Qualcom Adreno 630 GPU.
Driver version: 25.18.10440.0

P3 & unassigned -> wontfix 71

Reproducible on latest Nightly 73.0a1 (2019-12-12) (64-bit) on the same Lenovo Yoga laptop with Qualcom Adreno 630 GPU.
Driver version: 25.18.10440.0

As in comment 6, I'd like this to stay out of regression triage, and there is no need to keep marking current versions as affected.
That said, Jean-Yves is there some way we can block that particular graphics driver or communicate with Qualcomm (since the updated driver doesn't seem to have improved this?)

Flags: needinfo?(jyavenard)

do you still experience green frames with the latest drivers?

if not, I'm not sure that there's much more we can do now that HW acceleration would have been made active again

Flags: needinfo?(jyavenard) → needinfo?(tbabos)

Green screens are not being observed with this driver. Furthermore, I haven't observed any BSOD or system crashes so far.
However, this original issue still occurs on Lenovo Yoga C630-13Q50 with Windows 10 Home v1903, OS build 18362.535 and GPU driver Qualcomm Incorporated v25.18.10440.0 on Nightly v74.0a1 from 2020-01-13. Reddit performs poorly.

Flags: needinfo?(tbabos)

This issue was reproducible on Windows 10 with Firefox Nightly version 74.0a1 (2020-01-14) (64-bit). Marked as affected.

This issue is ARM64 specific and does not need further flag updates as stated by Liz in Comment 10. Please don't update the flags in the future.

Has Regression Range: --- → yes
Depends on: media-reddit
Severity: normal → S3

The severity field for this bug is relatively low, S3. However, the bug has 3 duplicates.
:jimm, could you consider increasing the bug severity?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jmathies)
Resolution: --- → INVALID
Blocks: media-reddit
No longer depends on: media-reddit
You need to log in before you can comment on or make changes to this bug.