Load "tabprompts.css" as a document stylesheet in the XUL about:addons page to fix options_page modals regression

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
normal
RESOLVED FIXED
Last month
Last month

People

(Reporter: rpl, Assigned: rpl)

Tracking

68 Branch
mozilla68
Points:
---

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last month

In Bug 1473910 the "tabprompts.css" have been moved from tabprompts.xml to browser.xul (landed in Firefox 64), unfortunately the tab modals triggered from an options_page embedded in about:addons have test coverage, but the test doesn't check if the tabmodal has got the expected stylesheet rules applied and so we didn't notice the regression (until we were going to add support for the modals for the HMTL about:addons as part of Bug 1532724).

Bug 1532724 is going to taking care of ensuring that the options_page modals will have the expected stylesheet applied, but we should still fix the regression in the top level XUL about.addons page because we don't know yet if the new HTML about:addons page will be enabled by default in Firefox 68.

Assignee

Updated

Last month
Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 2

Last month
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/e3fc2a2d52de
Load tabprompts.css as document stylesheet in the XUL about:addons page. r=jaws

Comment 3

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.