Intermittent Android 4.3 crashtest "No tests run or test summary not found" following encrypted-track-with-bad-sample-description-index.mp4

RESOLVED FIXED in Firefox 68

Status

()

defect
P2
normal
RESOLVED FIXED
Last month
Last month

People

(Reporter: gbrown, Assigned: bryce)

Tracking

(Blocks 1 bug, Regression)

unspecified
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

Last month

Many of the recent failures in bug 1335554 occur in Android 4.3 crashtests. Most (all?) of those appear to happen during encrypted-track-with-bad-sample-description-index.mp4, recently added in bug 1533211.

For example:

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=244604686&repo=mozilla-central&lineNumber=3175

[task 2019-05-03T23:25:35.892Z] 23:25:35 ERROR - No tests run or test summary not found
[task 2019-05-03T23:25:35.892Z] 23:25:35 INFO - TinderboxPrint: crashtest<br/><em class="testfail">T-FAIL</em>

The log shows tests running, but the test summary is missing -- the reftest run did not complete.

Logcat has:

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=244604686&repo=mozilla-central&lineNumber=3038

[task 2019-05-03T23:25:35.261Z] 23:25:35     INFO -  05-03 16:24:54.970 I/Gecko   (  818): REFTEST TEST-LOAD | http://10.0.2.2:8854/tests/dom/media/test/crashtests/encrypted-track-with-bad-sample-description-index.mp4 | 268 / 380 (70%)
[task 2019-05-03T23:25:35.261Z] 23:25:35     INFO -  05-03 16:24:54.980 I/Gecko   (  818):
[task 2019-05-03T23:25:35.261Z] 23:25:35     INFO -  05-03 16:24:54.980 I/Gecko   (  818): {"action":"log","time":1556925894980,"thread":null,"pid":null,"source":"reftest","level":"DEBUG","message":"START http://10.0.2.2:8854/tests/dom/media/test/crashtests/encrypted-track-with-bad-sample-description-index.mp4"}
[task 2019-05-03T23:25:35.261Z] 23:25:35     INFO -  05-03 16:24:55.461 I/Gecko   (  818): ++DOMWINDOW == 45 (0x5f4f0000) [pid = 818] [serial = 586] [outer = 0x60233ee0]
[task 2019-05-03T23:25:35.261Z] 23:25:35     INFO -  05-03 16:24:58.420 I/Gecko   (  818): [818, Main Thread] WARNING: No active window: file /builds/worker/workspace/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
[task 2019-05-03T23:25:35.262Z] 23:25:35     INFO -  05-03 16:24:59.410 I/Gecko   (  818): [818, Main Thread] WARNING: No active window: file /builds/worker/workspace/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
[task 2019-05-03T23:25:35.262Z] 23:25:35     INFO -  05-03 16:25:16.190 I/ActivityManager(  275): Process com.android.settings (pid 427) has died.
[task 2019-05-03T23:25:35.262Z] 23:25:35     INFO -  05-03 16:25:18.020 I/ActivityManager(  275): Process android.process.media (pid 360) has died.
[task 2019-05-03T23:25:35.262Z] 23:25:35     INFO -  05-03 16:25:18.180 I/ActivityManager(  275): Process com.android.mms (pid 522) has died.
[task 2019-05-03T23:25:35.263Z] 23:25:35     INFO -  05-03 16:25:18.190 D/CountryDetector(  275): No listener is left
[task 2019-05-03T23:25:35.263Z] 23:25:35     INFO -  05-03 16:25:18.320 I/ActivityManager(  275): Process com.android.defcontainer (pid 644) has died.
[task 2019-05-03T23:25:35.263Z] 23:25:35     INFO -  05-03 16:25:18.420 I/ActivityManager(  275): Process com.svox.pico (pid 660) has died.
[task 2019-05-03T23:25:35.263Z] 23:25:35     INFO -  05-03 16:25:18.540 I/ActivityManager(  275): Process android.process.acore (pid 455) has died.
[task 2019-05-03T23:25:35.263Z] 23:25:35     INFO -  05-03 16:25:18.690 I/ActivityManager(  275): Process com.android.quicksearchbox (pid 673) has died.
[task 2019-05-03T23:25:35.264Z] 23:25:35     INFO -  05-03 16:25:19.280 I/ActivityManager(  275): Process com.android.launcher (pid 400) has died.
[task 2019-05-03T23:25:35.264Z] 23:25:35     INFO -  05-03 16:25:19.290 I/WindowState(  275): WIN DEATH: Window{41929ac8 u0 com.android.launcher/com.android.launcher2.Launcher}
[task 2019-05-03T23:25:35.264Z] 23:25:35     INFO -  05-03 16:25:20.370 I/ActivityManager(  275): Process com.android.inputmethod.latin (pid 376) has died.
[task 2019-05-03T23:25:35.264Z] 23:25:35     INFO -  05-03 16:25:20.370 W/ActivityManager(  275): Scheduling restart of crashed service com.android.inputmethod.latin/.LatinIME in 5000ms
[task 2019-05-03T23:25:35.265Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): Session failed to close due to remote exception
[task 2019-05-03T23:25:35.265Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): android.os.DeadObjectException
[task 2019-05-03T23:25:35.265Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at android.os.BinderProxy.transact(Native Method)
[task 2019-05-03T23:25:35.265Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at com.android.internal.view.IInputMethodSession$Stub$Proxy.finishSession(IInputMethodSession.java:292)
[task 2019-05-03T23:25:35.265Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at com.android.server.InputMethodManagerService.finishSessionLocked(InputMethodManagerService.java:1346)
[task 2019-05-03T23:25:35.266Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at com.android.server.InputMethodManagerService.clearClientSessionLocked(InputMethodManagerService.java:1337)
[task 2019-05-03T23:25:35.266Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at com.android.server.InputMethodManagerService.clearCurMethodLocked(InputMethodManagerService.java:1363)
[task 2019-05-03T23:25:35.266Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at com.android.server.InputMethodManagerService.onServiceDisconnected(InputMethodManagerService.java:1382)
[task 2019-05-03T23:25:35.266Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at android.app.LoadedApk$ServiceDispatcher.doDeath(LoadedApk.java:1111)
[task 2019-05-03T23:25:35.267Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at android.app.LoadedApk$ServiceDispatcher$RunConnection.run(LoadedApk.java:1125)
[task 2019-05-03T23:25:35.267Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-05-03T23:25:35.267Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-05-03T23:25:35.267Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at android.os.Looper.loop(Looper.java:137)
[task 2019-05-03T23:25:35.267Z] 23:25:35     INFO -  05-03 16:25:20.470 W/InputMethodManagerService(  275): 	at com.android.server.ServerThread.run(SystemServer.java:1000)
[task 2019-05-03T23:25:35.268Z] 23:25:35     INFO -  05-03 16:25:21.250 I/Choreographer(  818): Skipped 45 frames!  The application may be doing too much work on its main thread.
[task 2019-05-03T23:25:35.268Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275): Applications Memory Usage (kB):
[task 2019-05-03T23:25:35.268Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275): Uptime: 1817454 Realtime: 1817454
[task 2019-05-03T23:25:35.268Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275): Total PSS by OOM adjustment:
[task 2019-05-03T23:25:35.268Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):     18195 kB: System
[task 2019-05-03T23:25:35.269Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):                18195 kB: system (pid 275)
[task 2019-05-03T23:25:35.269Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):     26165 kB: Persistent
[task 2019-05-03T23:25:35.272Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):                20147 kB: com.android.systemui (pid 334)
[task 2019-05-03T23:25:35.272Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):                 6018 kB: com.android.phone (pid 390)
[task 2019-05-03T23:25:35.272Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):    738709 kB: Foreground
[task 2019-05-03T23:25:35.274Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):               727045 kB: org.mozilla.fennec_aurora (pid 818)
[task 2019-05-03T23:25:35.274Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):                11664 kB: org.mozilla.fennec_aurora:media (pid 1216)
[task 2019-05-03T23:25:35.274Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):      4228 kB: Perceptible
[task 2019-05-03T23:25:35.274Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):                 4228 kB: com.android.inputmethod.latin (pid 376)
[task 2019-05-03T23:25:35.274Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):
[task 2019-05-03T23:25:35.274Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275): Total PSS: 787297 kB
[task 2019-05-03T23:25:35.274Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):       KSM: 0 kB saved from shared 0 kB
[task 2019-05-03T23:25:35.275Z] 23:25:35     INFO -  05-03 16:25:22.930 I/ActivityManager(  275):            0 kB unshared; 0 kB volatile
[task 2019-05-03T23:25:35.275Z] 23:25:35     INFO -  05-03 16:25:23.120 I/ActivityManager(  275): Process org.mozilla.fennec_aurora (pid 818) has died.
[task 2019-05-03T23:25:35.275Z] 23:25:35     INFO -  05-03 16:25:23.130 E/GeckoRemoteCodec( 1216): Callbacks is dead
[task 2019-05-03T23:25:35.275Z] 23:25:35     INFO -  05-03 16:25:23.140 I/GeckoMediaManager( 1216): Media service has been unbound. Stopping.
[task 2019-05-03T23:25:35.275Z] 23:25:35     INFO -  05-03 16:25:23.150 W/InputDispatcher(  275): channel '41964e48 org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp (server)' ~ Consumer closed input channel or an error occurred.  events=0x9
[task 2019-05-03T23:25:35.275Z] 23:25:35     INFO -  05-03 16:25:23.150 E/InputDispatcher(  275): channel '41964e48 org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp (server)' ~ Channel is unrecoverably broken and will be disposed!
[task 2019-05-03T23:25:35.276Z] 23:25:35     INFO -  05-03 16:25:23.180 I/WindowState(  275): WIN DEATH: Window{41965238 u0 SurfaceView}
[task 2019-05-03T23:25:35.276Z] 23:25:35     INFO -  05-03 16:25:23.190 I/WindowState(  275): WIN DEATH: Window{41964e48 u0 org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp}

...the system is running out of memory and killing processes?

Reporter

Comment 1

Last month

:bryce -- If this cannot be fixed easily, please skip the test on android.

Flags: needinfo?(bvandyk)
Regressed by: 1533211
Assignee

Comment 2

Last month

Thanks for pointing this out. My initial suspicion is that we have a legitimate issue on Android that is being highlighted by this new test. I'll look into removing that test from the Android runs for now, and raise another bug to follow up and figure out why this is happening and fix as needed.

Flags: needinfo?(bvandyk)
Assignee

Comment 3

Last month

encrypted-track-with-bad-sample-description-index.mp4 appears to be causing
issues when running under Android. Skip this when running crash tests while we
investigate and add a comment to indicate as such. Bug 1550912 has been raised
to follow this up and fix as needed.

Reporter

Updated

Last month
Priority: -- → P2

Comment 5

Last month
Pushed by bvandyk@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d33ae8976849
Skip problematic mp4 crashtest on Android while we investigate. r=jolin

Comment 6

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.