[File a new bug if this happens again] Intermittent browser_aboutPrefs_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm

RESOLVED DUPLICATE of bug 1546957

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1546957
2 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure, regression})

unspecified
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox66 unaffected, firefox67 unaffected, firefox67.0.1 unaffected, firefox68 fix-optional)

Details

Filed by: cbrindusan [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=245628373&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/Icjsk_ogScW1VzzIMmXYWw/runs/0/artifacts/public/logs/live_backing.log


22:45:18 INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js
22:45:18 INFO - GECKO(2596) | ++DOCSHELL 0FCE7800 == 21 [pid = 2556] [id = {85c3acbe-fd9c-40e5-8bd5-0638bb05fe4e}]
22:45:18 INFO - GECKO(2596) | ++DOMWINDOW == 66 (2516BCA0) [pid = 2556] [serial = 80] [outer = 00000000]
22:45:18 INFO - GECKO(2596) | ++DOMWINDOW == 67 (17A90000) [pid = 2556] [serial = 81] [outer = 2516BCA0]
22:45:18 INFO - GECKO(2596) | ++DOMWINDOW == 68 (2A013800) [pid = 2556] [serial = 82] [outer = 2516BCA0]
22:45:19 INFO - GECKO(2596) | --DOMWINDOW == 0 (085A3800) [pid = 5404] [serial = 2] [outer = 00000000] [url = about:blank]
22:45:19 INFO - GECKO(2596) | ++DOCSHELL 279C5C00 == 22 [pid = 2556] [id = {f894c050-456a-4381-b4a8-931d25ad7269}]
22:45:19 INFO - GECKO(2596) | ++DOMWINDOW == 69 (286D95E0) [pid = 2556] [serial = 83] [outer = 00000000]
22:45:19 INFO - GECKO(2596) | [Parent 2556, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file z:/build/build/src/dom/base/nsContentUtils.cpp, line 3656
22:45:19 INFO - GECKO(2596) | ++DOCSHELL 279C7400 == 23 [pid = 2556] [id = {b18f5ddb-36c3-412e-bd37-1a585f74ff37}]
22:45:19 INFO - GECKO(2596) | ++DOMWINDOW == 70 (286D9820) [pid = 2556] [serial = 84] [outer = 00000000]
22:45:19 INFO - GECKO(2596) | ++DOMWINDOW == 71 (279C3C00) [pid = 2556] [serial = 85] [outer = 286D95E0]
22:45:19 INFO - GECKO(2596) | ++DOMWINDOW == 72 (23F92400) [pid = 2556] [serial = 86] [outer = 286D9820]
22:45:19 INFO - GECKO(2596) | --DOCSHELL 08FB9800 == 2 [pid = 4284] [id = {4f087c06-9a17-4d17-b8b4-f8349bb045aa}] [url = about:blank]
22:45:19 INFO - GECKO(2596) | --DOCSHELL 01562000 == 1 [pid = 4284] [id = {f8f7dc76-156f-42b4-901b-2165ce166ddb}] [url = about:blank]
22:45:19 INFO - GECKO(2596) | --DOMWINDOW == 7 (08F364C0) [pid = 4284] [serial = 8] [outer = 00000000] [url = about:blank]
22:45:19 INFO - GECKO(2596) | --DOMWINDOW == 6 (08F36B80) [pid = 4284] [serial = 12] [outer = 00000000] [url = about:blank]
22:45:19 INFO - GECKO(2596) | --DOMWINDOW == 5 (08F36280) [pid = 4284] [serial = 10] [outer = 00000000] [url = about:blank]
22:45:19 INFO - [4764, Main Thread] WARNING: No active window: file z:/build/build/src/js/xpconnect/src/XPCJSContext.cpp, line 662
22:45:20 INFO - GECKO(2596) | JavaScript error: resource://gre/modules/Bits.jsm, line 79: Error: BitsError {type: 50, action: 6, stage: 2, codeType: none}
22:45:20 INFO - GECKO(2596) | --DOMWINDOW == 0 (089A1800) [pid = 636] [serial = 2] [outer = 00000000] [url = about:blank]
22:45:20 INFO - TEST-INFO | started process screenshot
22:45:20 INFO - TEST-INFO | screenshot: exit 0
22:45:20 INFO - Buffered messages logged at 22:45:18
22:45:20 INFO - Entering test bound setupTestCommon
22:45:20 INFO - Leaving test bound setupTestCommon
22:45:20 INFO - Entering test bound aboutPrefs_foregroundCheck_completeBadSize
22:45:20 INFO - Buffered messages logged at 22:45:19
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | The panel ID should equal checkingForUpdates - "checkingForUpdates" == "checkingForUpdates" -
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | There should not be an active update -
22:45:20 INFO - Buffered messages logged at 22:45:20
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | The panel ID should equal downloading - "downloading" == "downloading" -
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | There should be an active update -
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | The active update state should equal downloading -
22:45:20 INFO - Console message: [JavaScript Error: "Error: BitsError {type: 50, action: 6, stage: 2, codeType: none}" {file: "resource://gre/modules/Bits.jsm" line: 79}]
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | The patch property bitsResult value should equal 2147549183 -
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | The panel ID should equal downloadFailed - "downloadFailed" == "downloadFailed" -
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | There should not be an active update -
22:45:20 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | The panel's link href should equal http://127.0.0.1:8888/ - "http://127.0.0.1:8888/" == "http://127.0.0.1:8888/" -
22:45:20 INFO - Buffered messages finished
22:45:20 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5

OS: Unspecified → Windows
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Summary: Intermittent toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm → [File a new bug if this happens again] Intermittent browser_aboutPrefs_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm
Duplicate of bug: 1546957
You need to log in before you can comment on or make changes to this bug.