Closed Bug 1550710 Opened 1 year ago Closed 17 days ago

SVG containing downsized image displayed with img tag has pixel aliasing (flutter.dev logo)

Categories

(Core :: ImageLib, defect, P3)

68 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla79
Webcompat Priority ?
Tracking Status
firefox68 --- wontfix
firefox79 --- verified

People

(Reporter: ke5trel, Assigned: aosmond)

References

Details

Attachments

(2 files)

Bug 1534188 improved raster image downsizing for SVGs (confirmed in Bug 1538180), however if the SVG is displayed with an img tag like the flutter.dev logo it still has pixel aliasing.

The priority flag is not set for this bug.
:aosmond, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(aosmond)

I'll take a look at this soon.

Priority: -- → P3

Sorry this took longer than I thought. When we rasterize the SVG image into its own buffer:

https://searchfox.org/mozilla-central/rev/23d4bffcad365e68d2d45776017056b76ca9a968/image/VectorImage.cpp#306

We actually forget the FLAG_HIGH_QUALITY_SCALING. We should probably pass that through as PaintFrameFlags::ToWindow to ensure the lower levels get the flag set as expected.

Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Flags: needinfo?(aosmond)

We did not pass FLAG_HIGH_QUALITY_SCALING down to the document used to
rasterize the SVG to a surface, resulting in embedded raster images to
not use high quality downscaling.

new try after rewriting to use a dedicated flag in various places: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9c5345ff57eaafede8ac1838ece04fd048e5390a

Duplicate of this bug: 1645886
Webcompat Priority: --- → ?

needinfo to make sure this doesn't drop off the radar

Flags: needinfo?(aosmond)

Just waiting for it to be picked up by autoland.

Flags: needinfo?(aosmond)
Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6bcb0cefd0b9
Make vector images enable high quality scaling for embedded raster images. r=tnikkel
Status: ASSIGNED → RESOLVED
Closed: 17 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Flags: qe-verify+

Reproduced the issue with Firefox Nightly 68.0a (2019-05-10) on Windows 10x64.
Verified as fixed with Firefox 80.0a1 and Firefox 79.0b3 on Windows 10x64, Ubuntu 16.4 and macOS 10.13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.