Closed Bug 1550753 Opened 1 year ago Closed 1 year ago

Tab navigation could be improved for the menu bar customized Edit controls/Zoom control

Categories

(Firefox :: Toolbars and Customization, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1545382
Tracking Status
firefox67 --- affected
firefox68 --- affected

People

(Reporter: Anca, Unassigned)

Details

Attachments

(1 file)

Attached image screencast issue.gif

[Affected versions]:

  • 68.0a1 (2019-05-10)
  • 67.0b19

[Affected platforms]:

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.13

[Steps to reproduce]:

  1. From Menu - Customize drag and drop Edit Controls or Zoom control inside the menu bar next to the urlbar's right side.
  2. Navigate the menu bar using Tab key

[Expected result]:

  • The entire section of the Edit Controls/Zoom Controls item can be navigated using tab.

[Actual result]:

  • Only the first element is brought to focus - zoom out (ctrl+-), respectively cut (ctrl+x).

[Regression range]:
-Not a regression, new focus styling for toolbar buttons was implemented in bug 1506510.

[Additional Notes]:

  • The items as a whole can be accessed without any issue using the navigation arrows.
Has STR: --- → yes
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1545382
You need to log in before you can comment on or make changes to this bug.