Closed Bug 1550799 Opened 7 months ago Closed 7 months ago

Add a test for the restart button displaying in the update UI before it should during staging

Categories

(Toolkit :: Application Update, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: bytesized, Assigned: robert.strong.bugs)

References

Details

Attachments

(1 file)

Bug 1546627 was filed because loading the update UIs in about:preferences or "Help -> About Firefox" during update staging was not working properly.

A test should be added to check for this so we know if this regresses.

Summary: Add a test for loading the update UI during staging → Add a test for the restart button displaying in the update UI before it should during staging
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED

This adds tests for opening the about dialog and about preferences when an update is in the middle of being staged which was fixed in bug 1546627.
This also adds tests for opening the about dialog and about preferences when an update is in the middle of being downloaded
Changed the variable info to data in head.js since SimpleTest already has a function named info.
The test entries in browser.ini were reordered so it is easier to compare with the test entries in browser.bits.ini

Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a6445a0726c0
Add tests for opening the about dialog and about preferences when an update is downloading and when an update is staging. r=bytesized
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Regressions: 1551416
Depends on: 1551841
You need to log in before you can comment on or make changes to this bug.