Tracelogger not outputting correct script events when baseline is enabled

RESOLVED FIXED in Firefox 68

Status

()

defect
P2
normal
RESOLVED FIXED
2 months ago
Last month

People

(Reporter: denispal, Assigned: denispal)

Tracking

(Regression)

Trunk
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

2 months ago

Tracelogger is continuously disabling itself early due to bad script event id's that are being started. This problem is specific to generator JSOP RESUME opcodes, the script events that are passed in with emitTraceLoggerResume() are always garbage.

This appears to be because the baseline script is no longer loaded in the scratch1 register here: https://searchfox.org/mozilla-central/rev/b949ce10fd1d90e70a14b31dfdb72a3911d57108/js/src/jit/BaselineCompiler.cpp#5647-5656

Assignee

Comment 1

2 months ago

Tracelogger is no longer functioning properly because of bad script event ids. The baselinescript load into scratch1 was accidentally removed leading garbage script ids to be passed into emitTraceLoggerResume. This fix aims to simply reload the correct value back into scratch1 before calling tracelogger.

Assignee

Updated

Last month
Keywords: checkin-needed

Comment 2

Last month

Pushed by aciure@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/419436973f91
Load the baselinescript into scratch1 before calling emitTraceLoggerResume r=jandem

Keywords: checkin-needed

Comment 3

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.