Closed Bug 1550811 Opened 2 years ago Closed 2 years ago

Back out bug 325352 for now

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla68
Root Cause Design Error
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 blocking fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: crash regression that needs a fix before release.

Given how close we are to merge day, the crash volume from bug 1550524, and the complexity of the likely fix, I think we should back out bug 325352 for the moment and then reland it together with a fix for bug 1550524.

In particular, I would like to back out bug 325352 part 2.

Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/08eb61c33795
Back out the second part of the fix for bug 325352 until we have a fix for the crash issues it causes.  r=hsivonen
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → bzbarsky
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16931 for changes under testing/web-platform/tests
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2d19fd4d13f
[wpt PR 16931] - [Gecko Bug 1550811] Back out the second part of the fix for bug 325352 until we have a fix for the crash issues it causes., a=testonly

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?

Hi Henri, could you help specify a root cause for this bug? Thank you.

Flags: needinfo?(hsivonen)

The root cause is that the the code predates the spec, the spec tries to capture the browsers' collective pre-existing behavior, and then changing the code according to the spec didn't account for all actual Gecko-internal dependent behaviors. I've asked on Slack how this kind of thing should be annotated.

Flags: needinfo?(hsivonen)

Design Error per Slack.

Root Cause: ? → Design Error
You need to log in before you can comment on or make changes to this bug.