Closed Bug 1550861 Opened 4 months ago Closed 3 months ago

Trailhead final uplift

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
69.1 - May 13 - 26
Tracking Status
firefox67 --- wontfix
firefox67.0.1 blocking verified

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

Attachments

(2 files)

[Tracking Requested - why for this release]: We don't want this for 67.0/rcs. Will use this to track bugs blocking this uplift.

See Also: → 1550714
Depends on: 1550572
Depends on: 1550858
Iteration: --- → 69.1 - May 13 - 26
Priority: -- → P1
Depends on: 1551540
Depends on: 1551207
Assignee: nobody → edilee
Depends on: 1551677
Depends on: 1551832

Tracked for 67.0.5

Depends on: 1551951

Bug 1547830 is tracking 67.0.5 and will most likely get uplifted separately from newtab related changes.

No longer depends on: 1547830
Depends on: 1553205

Comment on attachment 9066210 [details]
Bug 1550861 - Trailhead final uplift

Beta/Release Uplift Approval Request

  • User impact if declined: New users would get the old about:welcome experience instead of the new trailhead messaging
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Test plan: https://docs.google.com/document/d/1rYKKM3Jz4Bg-569SdAL5imj_uVKg2n3IiZjoCDgRkJg
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): This changes the default about:welcome experience for en/de/fr locales to run 2 experiments with 9 total branches, and the only way to turn them off given the first run nature is with another code change / dot release. Most of the changes that are behind the default pref have already been verified on nightly (~35 verified with ~5 more to be verified soon), and these changes are to a feature that is shown once to new users with no other dependent features, so overall the risk is lower.
  • String changes made/needed: Yes, various trailhead strings were updated since initial landing and have landed on mozilla-central reviewed by flod there and here
Attachment #9066210 - Flags: approval-mozilla-release?
Flags: qe-verify+

Comment on attachment 9066210 [details]
Bug 1550861 - Trailhead final uplift

Approved for 67.0.5, thanks.

Attachment #9066210 - Flags: approval-mozilla-release? → approval-mozilla-release+
Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(mcoman)
Flags: needinfo?(cmuresan)
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Depends on: 1553391

I manually triggered L10n-Rpk builds:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-release&searchStr=l10n&revision=df853c362664989e025d1206b59c37c435186a91

Windows builds:
de https://queue.taskcluster.net/v1/task/R3IWmOgoR4iQwNYcgcuGXA/runs/0/artifacts/public/build/de/target.installer.exe
en-CA https://queue.taskcluster.net/v1/task/Ypo7tfLjQ0SK-UrwgbOZKQ/runs/0/artifacts/public/build/en-CA/target.installer.exe
en-GB https://queue.taskcluster.net/v1/task/eBDR3anySlibD-5XEX5Arw/runs/0/artifacts/public/build/en-GB/target.installer.exe
fr https://queue.taskcluster.net/v1/task/BeGQbepaTLCDq8joE5cnBA/runs/0/artifacts/public/build/fr/target.installer.exe
it https://queue.taskcluster.net/v1/task/b_9XXeHHQrynA93reXYU-g/runs/0/artifacts/public/build/it/target.installer.exe

Mac builds:
de https://queue.taskcluster.net/v1/task/J3k3EZMrQxu3OMYggWLAog/runs/0/artifacts/public/build/de/target.dmg
en-CA https://queue.taskcluster.net/v1/task/G7fSObxKS7W81X6RqD0s_g/runs/0/artifacts/public/build/en-CA/target.dmg
en-GB https://queue.taskcluster.net/v1/task/G9nUItjTQbOhByZt4SYM-A/runs/0/artifacts/public/build/en-GB/target.dmg
fr https://queue.taskcluster.net/v1/task/EQLDul2XR9yNB-5CaaDbRg/runs/0/artifacts/public/build/fr/target.dmg
it https://queue.taskcluster.net/v1/task/Bzc0mmIRRzm7SgngyhXsfw/runs/0/artifacts/public/build/it/target.dmg

Linux builds:
de https://queue.taskcluster.net/v1/task/TgVtOQUtRe-3g15s7eMlQA/runs/0/artifacts/public/build/de/target.tar.bz2
en-CA https://queue.taskcluster.net/v1/task/IJV9MoT2S3asBD51sQ0vHw/runs/0/artifacts/public/build/en-CA/target.tar.bz2
en-GB https://queue.taskcluster.net/v1/task/IJV9MoT2S3asBD51sQ0vHw/runs/0/artifacts/public/build/en-GB/target.tar.bz2
fr https://queue.taskcluster.net/v1/task/TYHp3G2GSAy4F3vSs4Bo9A/runs/0/artifacts/public/build/fr/target.tar.bz2
it https://queue.taskcluster.net/v1/task/Fx5MgWT0QQuQhNm1mEe2GA/runs/0/artifacts/public/build/it/target.tar.bz2

Sign off was sent as GREEN. Removing the ni? and marking as Verified - Fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(mcoman)
Flags: needinfo?(cmuresan)
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.