{css2} absolutely positioned overflowing text has undefined rendering

VERIFIED FIXED

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: ian, Assigned: troy)

Tracking

({css2})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

20 years ago
When an element is absolutely positioned, and the background is not
transparent, and the background doesn't completely cover the font, then the
areas of the background that the font does not cover will have an undefined
background, leaving large bits of gack behind.

See this test case:
http://www.bath.ac.uk/~py8ieh/internet/projects/mozilla/absolute-font-paint.html

Note. To make this obvious you may have to resize your window a lot, or visit
a black-on-white page then jump to this page.
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Assignee

Comment 1

20 years ago
Looks like a recent regression when Peter and I added code to make sure the view
visibility was correct.

What happened is that the view is marked as fully opaque, when it should not
because, as you noted, the text is spilling outside of the background and hence
the overflow should be transparent
Assignee

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 2

20 years ago
With the Oct 13th build 1999101312, the problem is fixed.
Reporter

Updated

20 years ago
Keywords: css2
Reporter

Comment 3

20 years ago
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
You need to log in before you can comment on or make changes to this bug.