Add minimum size to panes

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
2 months ago
Last month

People

(Reporter: the.derekli, Assigned: the.derekli)

Tracking

68 Branch
Firefox 68

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

Assignee

Description

2 months ago

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36

Steps to reproduce:

Set maxSize="70%" (previously set to 70% in horizontal mode and 95% in vertical mode which didn't make sense to me because what can you see with 5% of the window) to the initial SplitBox preventing either primary or secondary panes from becoming too small

Assignee

Comment 1

2 months ago

Set a maximum size for panes

Assignee

Comment 2

2 months ago

Part of a set of changes from https://github.com/firefox-devtools/debugger/pull/8200 that David asked me to separate

Comment 3

Last month

Hi @Derek, I've tested your issue:
[Platform used]: Windows 10
[Firefox versions]: release 66.0.5 and latest nightly 68.0a1

On my end the issue cannot be reproduced. Please fell free to add more info's in order to figure it out how to reproduce the issue.
Thanks for your contribution.

Component: Untriaged → Inspector
Flags: needinfo?(the.derekli)
Product: Firefox → DevTools
Assignee

Comment 4

Last month

Breakpoints pane can take up 95% of the window space in horizontal mode which doesn't really make sense in the context of debugging (cannot even see code anymore).

Flags: needinfo?(the.derekli)
Assignee

Comment 5

Last month

After the change it won't be possible to increase the ratio of breakpoints pane to editor pane beyond this

Assignee

Comment 6

Last month

Hey @Livlu,

We discussed adding a minimum size to the editor and secondary panes in this GitHub issue: https://github.com/firefox-devtools/debugger/issues/8127 (second comment).

I believe the change is necessary since having one of the panes take up to 95% of the window doesn't really make any sense in the context of debugging as you cannot see the code/breakpoints anymore.

Sorry my steps to reproduce were unclear.

Steps to reproduce:

  1. Open debugger in vertical mode
  2. Try to make breakpoints pane as large as you can (should completely take up the view port)

Comment 7

Last month
Pushed by dwalsh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b820404d54be
Change max size of Secondary and Editor panes r=davidwalsh

Comment 8

Last month
Posted image Console -Debugger resizing.png (obsolete) —

Comment 9

Last month
Attachment #9064990 - Attachment is obsolete: true

Comment 10

Last month

Hi @Derek, re-tested the issue but still cannot reproduce. I will add a screenshot to see how it looks on my end.
Additionally, when you make a screenshot please make it with entire zone, I mean the whole perspective not just a piece.
Thanks

Comment 11

Last month
bugherder
Status: UNCONFIRMED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → the.derekli
You need to log in before you can comment on or make changes to this bug.