Status

enhancement
RESOLVED FIXED
Last month
28 days ago

People

(Reporter: eijebong, Assigned: eijebong)

Tracking

(Blocks 1 bug)

Trunk
mozilla68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

Last month
No description provided.
Assignee

Updated

Last month
Product: Firefox → Firefox Build System
Assignee

Comment 1

Last month

Unfortunately the diff is kinda bug because this is the first crate
requiring rand 0.6 which has been split into multiple crates.

Assignee

Comment 2

Last month

So the revendor of this contains non utf-8 stuff, that made moz-phab crash so I had to cheat a little bit.. Hopefully everything is still Ok

Assignee

Comment 3

Last month

It was unhappy about the new LICENSE (fuchsia-cprng) but it's the same
as the other fuschia crates. Since I don't think this is used at build
time but has the same license as the other fuschia crates, I put it in
the RUNTIME_LICENSE_PACKAGE_WHITELIST list. I also removed sha1 from
that list as it's not used anymore

As someone who frequently has to dig through source history to figure out why things are the way they are, I get really frustrated by commits that don't have any reason given. Could you please do at least one of the following, bonus points if you do all three:

  • Write in this bug why ws needs to be updated to 0.8. (What new feature/bugfix does it bring?)
  • Do the same in the change description of part 1
  • Set the blocks/depends fields to link to some other bug that requires this work.

Thanks.

Assignee

Comment 5

Last month

This is needed to avoid duplicates of other dependencies. I'm slowly working to remove the other versions of rand (I already got rid of 0.5 earlier this month. Unfortunately this is a very slow moving process because I'm trying to do this part by part instead of updating half the crates in here... ws 0.8 mostly brings in rand 0.6 (it's the first dependency to require it), sha-1 since sha1 isn't maintained and hyper related things tend to depend on the former (let's try avoiding having two sha1 impls in there...)

I could open a bug for the rand deduplication work if that's really bothering you.

Assignee

Updated

Last month
Blocks: 1396824

This is needed to avoid duplicates of other dependencies.

Great, thanks. FWIW I'm a fan of such cleanup.

I could open a bug for the rand deduplication work if that's really
bothering you.

If a bunch of changes are landing for a common purpose, it would be useful to connect the bugs. Future code archaeologists will thank you. :-)

Comment 8

Last month
Pushed by eijebong@bananium.fr:
https://hg.mozilla.org/integration/autoland/rev/fe8d48740511
Part 2: Revendor dependencies. r=emilio,kats,froydnj
Assignee

Comment 9

Last month

I don't know how the first patch landed without the other.... Hopefully this will not break anything :/

Comment 10

Last month
bugherder
Status: UNCONFIRMED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → eijebong

This was backed out from central because of webrender bustages.
Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&resultStatus=busted%2Cexception&selectedJob=246291964&revision=96563508f9fed49ddc64469d05c9d3d7be46d547&searchStr=webrender

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=246291964&repo=mozilla-central

Backout link: https://hg.mozilla.org/mozilla-central/rev/30817917ace8ef05f5badd1522f7f1adac64d1e5

[task 2019-05-14T04:13:36.706Z] Progress: 99% (914/923)
[task 2019-05-14T04:13:36.747Z] Progress: 99% (915/923)
[task 2019-05-14T04:13:36.750Z] Progress: 99% (916/923)
[task 2019-05-14T04:13:36.750Z] Progress: 99% (917/923)
[task 2019-05-14T04:13:36.752Z] Progress: 99% (918/923)
[task 2019-05-14T04:13:36.758Z] Progress: 99% (919/923)
[task 2019-05-14T04:13:36.758Z] Progress: 99% (920/923)
[task 2019-05-14T04:13:36.758Z] Progress: 99% (921/923)
[task 2019-05-14T04:13:36.758Z] Progress: 99% (922/923)
[task 2019-05-14T04:13:36.793Z] Progress: 100% (923/923)
[task 2019-05-14T04:13:36.793Z] Running the dependency licensing lint...
[task 2019-05-14T04:13:36.793Z]
[taskcluster 2019-05-14 04:13:37.152Z] === Task Finished ===
[taskcluster 2019-05-14 04:13:37.153Z] Unsuccessful task run with exit code: 1 completed in 102.051 seconds

Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(eijebong)
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---

Comment 12

Last month
Pushed by eijebong@bananium.fr:
https://hg.mozilla.org/integration/autoland/rev/f48939dc27b6
Part 1: Update ws to 0.8. r=emilio
https://hg.mozilla.org/integration/autoland/rev/d62be51ffad3
Part 2: Revendor dependencies. r=emilio,kats,froydnj
Assignee

Comment 14

Last month

Damn, looks like I should've tried building wr on its own, not webrender locally... We ran into https://github.com/rust-random/rand/issues/766 but for rand_core 0.2.1/0.3.1 (which don't work together, should be 0.2.2 and 0.3.1...). Updating it fixed the compilation. I really wish rand would be better at respecting semver...

Here's a more in depth try build to avoid getting this backed out a third time... https://treeherder.mozilla.org/#/jobs?repo=try&revision=0dd70829f312c30f390d7e00787f8ef16f0c08b6

Flags: needinfo?(eijebong)

Comment 15

28 days ago
Pushed by eijebong@bananium.fr:
https://hg.mozilla.org/integration/autoland/rev/43f36577137b
Part 1: Update ws to 0.8. r=emilio
https://hg.mozilla.org/integration/autoland/rev/ffd30b61406d
Part 2: Revendor dependencies. r=emilio,kats,froydnj

Comment 16

28 days ago
bugherder
Status: REOPENED → RESOLVED
Closed: Last month28 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.