Will not display on Solaris or Linux

VERIFIED FIXED

Status

()

Core
XSLT
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Hugh Coomes, Assigned: peterv)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This URL is an xml file invoking an xls file.  It displays OK on MS Windows 2000
using build 2002061408, but does not display on Linux or Solaris with any build
I have tried (2002062800 On Solaris) of Mozilla1.1a.  The content of the URl is a
re-implementation of a Mozilla FAQ with an alternate style sheet.

On Linux or Solaris, current display does not change from the previous one
(whether a blank page or other page).

Comment 1

16 years ago
"but does not display on Linux"
wfm. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610 (SuSE)
yep, i see this too, though it would be nice with a bit smaller testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I'm seeing this break with Win2k 20020625 so that's an 11 day gap where the 
regression happened.

Comment 4

16 years ago
After the checkin for bug 158457 yesterday (20021022), Mozilla correctly
displays the URL as "Mozilla 1.0 Frequently Asked Questions" on Solaris 2.6 from
sparc-sun-solaris-2.6 nightly build (20021023) and on FreeBSD 4.6.1 from CVS
build  (20021022).
(Reporter)

Comment 5

16 years ago
This URL now displays also using Mozilla/5.0 (X11; U; SunOS sun4u; en-US;
rv:1.2b) Gecko/20021024 compiled with Sun Compiler v. 6u2.   However all
versions I have
tried, included daily builds for Solaris, exhibit the following behavior: If the
default "non-dynamic" style sheet is used, when click on a FAQ several items in
the View menu are then disabled. Using the back arrow to display the original page
does not enable these items. Is this normal behavior?

Comment 6

16 years ago
oops, after going to a fragment, the View->Use Style menu gets disabled.

http://lxr.mozilla.org/seamonkey/source/xpfe/browser/resources/content/navigatorOverlay.xul#261
obviously thinks we're an image document.
Looking into lxr says that someone in
http://lxr.mozilla.org/seamonkey/source/xpfe/browser/resources/content/nsBrowserStatusHandler.js#282
or #331 said so.
Both ask 
http://lxr.mozilla.org/seamonkey/source/xpfe/browser/resources/content/nsBrowserStatusHandler.js#170

Note that the page info dialog reports an unkown mimetype, maybe we failed to
set that in the result doc? Jonas? Quirks isn't set either.
can anyone still reproduce this? It works for me

Comment 8

15 years ago
hrm. I left this open to check for the fragment/view/mime thing.
testing on 1.3b windows, the view menu is fine, but going to a fragment
from the index seems to be broken.
New bug on same page?
Ouch, that's bad, but please file a new bug for that (I might have an idea what
the problem is). This one is confuesed as it is. Resolving as fixed as comment 4
indicates that this was related to <script> locking things up
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 10

15 years ago
filed bug 196026

Comment 11

15 years ago
mass verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.