Closed Bug 1550967 Opened 1 year ago Closed 1 year ago

"services.sync.username" being reset

Categories

(Firefox :: Sync, defect, P2)

68 Branch
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: Tobias.Marty, Assigned: markh)

References

Details

Attachments

(1 file)

My logged in profile for Sync only gets enabled after starting a new instance of Firefox after manually clicking on "Sign in to Sync" in the hamburger menu. Otherwise Sync just won't work anymore. This issue is persisting for a while now. I notice this in my main Nightly profile but also in an installation of Firefox 67 Beta on another Windows 10 machine.

Thanks for the report, and sorry to hear Firefox is giving you a bad experience here. We sometimes see issues like this when users have a third-party password manager installed, because Sync stores its credentials in the Firefox password manager. Are you using a third-party password management add-on by any chance?

Flags: needinfo?(Tobias.Marty)

(In reply to TMart from comment #0)

My logged in profile for Sync only gets enabled after starting a new instance of Firefox after manually clicking on "Sign in to Sync" in the hamburger menu.

Do you have to take any further action after clicking "Sign in to Sync", such as actually logging in, or does it magically start working immediately after that?

In addition to Ryan's question, could you please visit about:config and see if there's any values shown for the "services.sync.username" preference?

Are you using a third-party password management add-on by any chance?

I don't.

Do you have to take any further action after clicking "Sign in to Sync", such as actually logging in, or does it magically start > working immediately after that?

It starts magically working again.

In addition to Ryan's question, could you please visit about:config and see if there's any values shown for the
"services.sync.username" preference?

This pref doesn't exist.

Flags: needinfo?(Tobias.Marty)

I added the pref services.sync.username, set it to my Syn account name and it seems to be working now!

The priority flag is not set for this bug.
:markh, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(markh)

I encountered this on multiple installations after upgrading to newer Firefox (Beta) versions. In all cases it could be fixed by manually adding said pref.

Thanks! This isn't the first report and I'd really like to better understand why it is being reset, but I think there's a relatively easy fix here - we should just set that pref whenever we notice there is a user signed in - currently we only do it once at signin time)

Assignee: nobody → markh
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(markh)
Priority: -- → P2
Summary: After restart Sync needs to be manually enabled → "services.sync.username" being reset
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/006da247f592
ensure sync's username pref is set whenever FxA has a user. r=tcsc
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
See Also: → 1530660

Comment on attachment 9070892 [details]
Bug 1550967 - ensure sync's username pref is set whenever FxA has a user. r?tcsc

Beta/Release Uplift Approval Request

  • User impact if declined: Users who ever suffered from bug 1530660 find themselves apparently disconnected from sync on each startup
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Very small patch that sets one pref in some cases.
  • String changes made/needed:
Attachment #9070892 - Flags: approval-mozilla-beta?

Comment on attachment 9070892 [details]
Bug 1550967 - ensure sync's username pref is set whenever FxA has a user. r?tcsc

fxa fix for 68.0b10

Attachment #9070892 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Build ID 20190613215335
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Build ID 20190613141208
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Verified as fixed on the latest Nightly build and latest Beta build (v68b10) on Windows 10.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.