Render task graph and shadow stack cleanups.

RESOLVED FIXED

Status

()

task
P3
normal
RESOLVED FIXED
Last month
Last month

People

(Reporter: nical, Assigned: nical)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Assignee

Description

Last month

Followups to patches that landed in bug 1536021 and bug 1543974.

Assignee

Comment 1

Last month

ColorMatrix is rarely used but takes most space in the Filter enum.
This removes 44 bytes from the enum and all structs that embed it.

Assignee

Comment 3

Last month

sed -i 's/RenderTaskTree/RenderTaskGraph/g' gfx/wr/webrender//*.rs
sed -i 's/task tree/task graph/g' gfx/wr/webrender/
/*.rs

Assignee

Updated

Last month
Keywords: leave-open

Comment 5

Last month
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa02e32fd5bf
Remove the single-shadow picture composite code. r=kvark

Comment 6

Last month
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc83934fa032
Rename render task tree into render task graph. r=kvark

Comment 7

Last month
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/333943819087
Box the color matrix in Filter. r=kvark

Backed out 3 changesets (Bug 1551187) for webrender bustages

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&fromchange=2fe5b3d2dca7c1883b6e6d4bca81da5dc349733b&searchStr=os%2Cx%2C10.10%2Cquantumrender%2Cdebug&tochange=52456bf79f9f9e7b26ecb5d9445d5f29fbd18627&selectedJob=246591407

Backout link: https://hg.mozilla.org/integration/autoland/rev/52456bf79f9f9e7b26ecb5d9445d5f29fbd18627

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=246591407&repo=autoland&lineNumber=1548

[task 2019-05-15T13:41:33.590Z] [webrender 0.60.0] cargo:rerun-if-changed=res/pf_vector_stencil.glsl
[task 2019-05-15T13:41:33.590Z] [webrender 0.60.0] cargo:rerun-if-changed=res/cs_line_decoration.glsl
[task 2019-05-15T13:41:45.747Z] Running CARGO_PKG_REPOSITORY='https://github.com/servo/webrender' CARGO_PKG_DESCRIPTION='A GPU accelerated 2D renderer for web content' CARGO_MANIFEST_DIR=/builds/worker/checkouts/gecko/gfx/wr/webrender CARGO=/builds/worker/workspace/build/src/rustc/bin/cargo OUT_DIR=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/build/webrender-a77d4270f1db5cd9/out CARGO_PKG_HOMEPAGE= CARGO_PKG_VERSION_PRE= CARGO_PKG_VERSION_MINOR=60 CARGO_PRIMARY_PACKAGE=1 LD_LIBRARY_PATH='/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps:/builds/worker/workspace/build/src/rustc/lib:/builds/worker/workspace/build/src/clang/lib:' CARGO_PKG_NAME=webrender CARGO_PKG_VERSION_PATCH=0 CARGO_PKG_VERSION_MAJOR=0 CARGO_PKG_VERSION=0.60.0 CARGO_PKG_AUTHORS='Glenn Watson <gw@intuitionlibrary.com>' rustc --edition=2018 --crate-name webrender webrender/src/lib.rs --color never --crate-type lib --emit=dep-info,metadata -C debuginfo=2 --cfg 'feature="api"' --cfg 'feature="default"' --cfg 'feature="freetype"' --cfg 'feature="freetype-lib"' --cfg 'feature="replay"' --cfg 'feature="ron"' --cfg 'feature="serde"' -C metadata=5978b3c51c99b030 -C extra-filename=-5978b3c51c99b030 --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps --target x86_64-apple-darwin -C linker=/builds/worker/checkouts/gecko/build/cargo-linker -C incremental=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/incremental -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --extern bincode=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libbincode-c9e59314ffbc5cb8.rmeta --extern bitflags=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libbitflags-ac53f158893c5cc6.rmeta --extern byteorder=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libbyteorder-75b95a9fb6d96a0c.rmeta --extern cfg_if=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcfg_if-0778298001a9853a.rmeta --extern core_foundation=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcore_foundation-0063a51886ca6935.rmeta --extern core_graphics=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcore_graphics-0328146af7fcd1fe.rmeta --extern core_text=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcore_text-4a33050d2ef3e48e.rmeta --extern cstr=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcstr-cf16b42f5cf09e43.rmeta --extern euclid=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libeuclid-7518ae8bab589c35.rmeta --extern fxhash=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libfxhash-efb1b5947ba2fd7a.rmeta --extern gleam=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libgleam-8f0e730dcb890a37.rmeta --extern lazy_static=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/liblazy_static-d28a2125ec6e4367.rmeta --extern log=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/liblog-53495940088c42c1.rmeta --extern malloc_size_of_derive=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libmalloc_size_of_derive-6b886f7c628c38c8.so --extern num_traits=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libnum_traits-093c6c8edc98d201.rmeta --extern plane_split=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libplane_split-515298866b0f536d.rmeta --extern rayon=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/librayon-742122685ef5915d.rmeta --extern ron=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libron-41079a459ecc44c0.rmeta --extern serde=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libserde-eba9de0327e8a466.rmeta --extern sha2=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libsha2-708920625c8b1707.rmeta --extern smallvec=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libsmallvec-7467ae335cfc44b2.rmeta --extern svg_fmt=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libsvg_fmt-d88d8fe4a8403522.rmeta --extern thread_profiler=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libthread_profiler-afaa5c896c10d1aa.rmeta --extern time=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libtime-4b69067c9ffb3700.rmeta --extern api=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libwebrender_api-7f83765e5b4ea9e2.rmeta --extern webrender_build=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libwebrender_build-15ff6bf62974614a.rmeta --extern malloc_size_of=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libwr_malloc_size_of-0e19419b28008bfa.rmeta --deny warnings
[task 2019-05-15T13:41:59.250Z] error[E0277]: the trait bound smallvec::SmallVec<[api::Shadow; 1]>: serde::Deserialize<'_> is not satisfied
[task 2019-05-15T13:41:59.250Z] --> webrender/src/internal_types.rs:53:21
[task 2019-05-15T13:41:59.250Z] |
[task 2019-05-15T13:41:59.250Z] 53 | DropShadowStack(SmallVec<[Shadow; 1]>),
[task 2019-05-15T13:41:59.250Z] | ^^^^^^^^ the trait serde::Deserialize<'_> is not implemented for smallvec::SmallVec<[api::Shadow; 1]>
[task 2019-05-15T13:41:59.250Z] |
[task 2019-05-15T13:41:59.250Z] = note: required by serde::de::VariantAccess::newtype_variant
[task 2019-05-15T13:41:59.250Z]
[task 2019-05-15T13:42:03.690Z] error: aborting due to previous error
[task 2019-05-15T13:42:03.690Z]
[task 2019-05-15T13:42:03.690Z] For more information about this error, try rustc --explain E0277.
[task 2019-05-15T13:42:03.734Z] error: Could not compile webrender.
[task 2019-05-15T13:42:03.734Z]
[task 2019-05-15T13:42:03.734Z] Caused by:
[task 2019-05-15T13:42:03.734Z] process didn't exit successfully: CARGO_PKG_REPOSITORY='https://github.com/servo/webrender' CARGO_PKG_DESCRIPTION='A GPU accelerated 2D renderer for web content' CARGO_MANIFEST_DIR=/builds/worker/checkouts/gecko/gfx/wr/webrender CARGO=/builds/worker/workspace/build/src/rustc/bin/cargo OUT_DIR=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/build/webrender-a77d4270f1db5cd9/out CARGO_PKG_HOMEPAGE= CARGO_PKG_VERSION_PRE= CARGO_PKG_VERSION_MINOR=60 CARGO_PRIMARY_PACKAGE=1 LD_LIBRARY_PATH='/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps:/builds/worker/workspace/build/src/rustc/lib:/builds/worker/workspace/build/src/clang/lib:' CARGO_PKG_NAME=webrender CARGO_PKG_VERSION_PATCH=0 CARGO_PKG_VERSION_MAJOR=0 CARGO_PKG_VERSION=0.60.0 CARGO_PKG_AUTHORS='Glenn Watson <gw@intuitionlibrary.com>' rustc --edition=2018 --crate-name webrender webrender/src/lib.rs --color never --crate-type lib --emit=dep-info,metadata -C debuginfo=2 --cfg 'feature="api"' --cfg 'feature="default"' --cfg 'feature="freetype"' --cfg 'feature="freetype-lib"' --cfg 'feature="replay"' --cfg 'feature="ron"' --cfg 'feature="serde"' -C metadata=5978b3c51c99b030 -C extra-filename=-5978b3c51c99b030 --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps --target x86_64-apple-darwin -C linker=/builds/worker/checkouts/gecko/build/cargo-linker -C incremental=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/incremental -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --extern bincode=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libbincode-c9e59314ffbc5cb8.rmeta --extern bitflags=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libbitflags-ac53f158893c5cc6.rmeta --extern byteorder=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libbyteorder-75b95a9fb6d96a0c.rmeta --extern cfg_if=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcfg_if-0778298001a9853a.rmeta --extern core_foundation=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcore_foundation-0063a51886ca6935.rmeta --extern core_graphics=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcore_graphics-0328146af7fcd1fe.rmeta --extern core_text=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcore_text-4a33050d2ef3e48e.rmeta --extern cstr=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libcstr-cf16b42f5cf09e43.rmeta --extern euclid=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libeuclid-7518ae8bab589c35.rmeta --extern fxhash=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libfxhash-efb1b5947ba2fd7a.rmeta --extern gleam=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libgleam-8f0e730dcb890a37.rmeta --extern lazy_static=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/liblazy_static-d28a2125ec6e4367.rmeta --extern log=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/liblog-53495940088c42c1.rmeta --extern malloc_size_of_derive=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libmalloc_size_of_derive-6b886f7c628c38c8.so --extern num_traits=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libnum_traits-093c6c8edc98d201.rmeta --extern plane_split=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libplane_split-515298866b0f536d.rmeta --extern rayon=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/librayon-742122685ef5915d.rmeta --extern ron=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libron-41079a459ecc44c0.rmeta --extern serde=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libserde-eba9de0327e8a466.rmeta --extern sha2=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libsha2-708920625c8b1707.rmeta --extern smallvec=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libsmallvec-7467ae335cfc44b2.rmeta --extern svg_fmt=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libsvg_fmt-d88d8fe4a8403522.rmeta --extern thread_profiler=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libthread_profiler-afaa5c896c10d1aa.rmeta --extern time=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libtime-4b69067c9ffb3700.rmeta --extern api=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libwebrender_api-7f83765e5b4ea9e2.rmeta --extern webrender_build=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libwebrender_build-15ff6bf62974614a.rmeta --extern malloc_size_of=/builds/worker/checkouts/gecko/gfx/wr/target/x86_64-apple-darwin/debug/deps/libwr_malloc_size_of-0e19419b28008bfa.rmeta --deny warnings (exit code: 1)
[taskcluster 2019-05-15 13:42:04.046Z] === Task Finished ===
[taskcluster 2019-05-15 13:42:04.164Z] Artifact "public/build/cargo-test-binaries.tar.bz2" not found at "/builds/worker/artifacts/cargo-test-binaries.tar.bz2"
[taskcluster 2019-05-15 13:42:04.482Z] Unsuccessful task run with exit code: 101 completed in 240.46 seconds

Flags: needinfo?(nical.bugzilla)

Comment 9

Last month
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/091801115a02
Remove the single-shadow picture composite code. r=kvark
https://hg.mozilla.org/integration/mozilla-inbound/rev/f92d432ffcc8
Rename render task tree into render task graph. r=kvark
https://hg.mozilla.org/integration/mozilla-inbound/rev/f8516287a425
Box the color matrix in Filter. r=kvark
Assignee

Updated

Last month
Flags: needinfo?(nical.bugzilla)

Comment 11

Last month
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/76e3a842e496
Rename DropShadowStack into DropShadows. r=kvark"
Assignee

Updated

Last month
Status: NEW → RESOLVED
Closed: Last month
Keywords: leave-open
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.