Closed Bug 1551202 Opened 3 months ago Closed 3 months ago

[about:addons] Support dark theme

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: mstriemer, Assigned: robwu)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

The in-content pages now support the dark theme when the OS is in dark mode. The HTML about:addons page should support this theme since currently there is a lot of black text on a black background.

STR

  • browser.in-content.dark-mode=true
  • ui.systemUsesDarkTheme=1
  • extensions.htmlaboutaddons.enabled=true
  • extensions.htmlaboutaddons.discover.enabled=true
  • extensions.abuseReport.enabled=1
  • extensions.getAddons.cache.enabled=true (this is already the default, but turned off when run via web-ext; this is needed to see the details at the details page)

Notes from robwu:

From a quick cursory visual inspection of about:addons in Nightly 68.0a1 buildID 20190512214232 on macOS, I see:

  • The card menu's text color is black; against a dark background it is illegible.
  • Most of the rows in the details page has a dark font (except for the heading and summary). (for comparison, see the XUL version, that looks a bit better (but still has some defects); screenshot at https://bugzilla.mozilla.org/show_bug.cgi?id=1544212 )
  • The radio inputs of the report abuse panel are hard to see (except when the radio is selected).
  • The message-bar always has a light appearance (this can easily be seen at the discopane) (this is also an issue in the old about:addons page, see the screenshot at https://bugzilla.mozilla.org/show_bug.cgi?id=1545346 ).

(updated summary to clarify that this is specific to about:addons).

Bug 1544111 introduced dark themes, but recently we have added new features that did not account for dark themes.

To fix this, we should use semantic variable names instead of color names.

Searchfox query to find todos

See Also: → 1544111
Summary: Support dark theme → [about:addons] Support dark theme

Tim, are you interested in updating the HTML about:addons style sheets to be fully dark theme friendly again?

Flags: needinfo?(ntim.bugs)

This bug should be added to the list of blockers for shipping the new HTML about:addons.

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #3)

This bug should be added to the list of blockers for shipping the new HTML about:addons.

This bug is already a blocker of bug 1533795, which in turn blocks bug 1505924.

I intend to submit a patch this week, unless Tim wants to take this bug.

Thanks! I wasn't sure based on the P2 priority on the bug :) (disregard me)

Duplicate of this bug: 1547558

In bug 1544111, I already fixed everything that wasn't dark mode friendly at the time that bug landed, but it looks like new features that landed since did not land with dark mode support.

I think it would be better if someone working on the new about:addons worked on this, to be able to sync up with further work on that page.

Flags: needinfo?(ntim.bugs)
Priority: P2 → P1

Most colors have been replaced with a variable that has the same color
value.

The exception is the border color at the add-on details.
--grey-90-a20 was replaced with --in-content-box-border-color,
whose value is --grey-90-a30. This is close enough.

  • Update info.svg to adjust color based on the fill color.

  • Use button colors as defined by Photon (without this, the background
    of the non-generic buttons are almost indistinguishable when dark
    themes are enabled).

  • Small refactor of message-bar.css to put all type-specific
    declarations in one location.

  • Put every color in a variable name.
  • Add label:hover so that the radio input provides visual feedback upon hover.
  • Implement "pressed" ([type="radio"]:active) and :focus{border:0}
    to match Photon's design guidelines at
    https://design.firefox.com/photon/components/radio-buttons.html
  • Implement dark theme for radio inputs (using creative freedom as there
    is no Photon guideline for this).
Assignee: nobody → rob
Status: NEW → ASSIGNED
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/5f5daca84fbe
Support dark theme at HTML about:addons r=jaws
https://hg.mozilla.org/integration/autoland/rev/145429781395
Update <message-bar> to fully match Photon's style r=jaws
https://hg.mozilla.org/integration/autoland/rev/70b0d5a417b8
Support dark theme for radio input at abuse reports r=jaws
Backout by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c07f5967e0fc
Backed out 3 changesets for Causing Bug 1550093 to break on browser_parsable_css.js

<jaws> bogdan_tara|sheriffduty: yes, if i view the mochitest-browser-chrome-chunked_raw.log for bc7 builds of bug 1551202 and those preceding bug 1550093, browser_parsable_css.js is not run
7:53 AM it is only run starting in bug 1550093
7:53 AM so this failure will start up again once it gets triggered again

Backout: https://hg.mozilla.org/integration/autoland/rev/c07f5967e0fc880bb9db128e98369f648a1884e2

[task 2019-05-17T23:32:41.474Z] 23:32:41 INFO - TEST-START | browser/base/content/test/static/browser_parsable_css.js
[or stock: Icon 'folder' not present in theme ubuntu-mono-dark

[task 2019-05-17T23:32:43.259Z] 23:32:43 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_parsable_css.js | custom property --messsage-bar-icon-url is not referenced -
[task 2019-05-17T23:32:43.261Z] 23:32:43 INFO - Stack trace:
[task 2019-05-17T23:32:43.262Z] 23:32:43 INFO - chrome://mochikit/content/browser-test.js:test_ok:1314
[task 2019-05-17T23:32:43.264Z] 23:32:43 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_css.js:checkAllTheCSS:453
[task 2019-05-17T23:32:43.265Z] 23:32:43 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
[task 2019-05-17T23:32:43.267Z] 23:32:43 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
[task 2019-05-17T23:32:43.268Z] 23:32:43 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1005
[task 2019-05-17T23:32:43.271Z] 23:32:43 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-05-17T23:32:43.272Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-has-dir-attr’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.274Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-dir-attr-rtl’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.275Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-dir-attr-ltr’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.277Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-dir-attr-like-auto’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.278Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-dir-attr-like-auto’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.280Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-has-dir-attr’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.281Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-dir-attr-like-auto’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.283Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-border-nonzero’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.284Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-border-nonzero’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.286Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-list-reversed’. Declaration dropped." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.287Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-list-reversed’. Declaration dropped." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.289Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-user-disabled’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.290Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-user-disabled’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.292Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-suppressed’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.293Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.295Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-html-canvas-content’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.296Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.298Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.299Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-min-font-size-ratio’. Declaration dropped." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.301Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-min-font-size-ratio’. Declaration dropped." on resource://gre-resources/html.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.302Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-canvas’. Ruleset ignored due to bad selector." on resource://gre/res/EditorOverride.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.304Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-display-comboboxcontrol-frame’. Ruleset ignored due to bad selector." on resource://gre/res/EditorOverride.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.305Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.308Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.309Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.315Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.316Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.321Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-mathml-anonymous-block’. Ruleset ignored due to bad selector." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.321Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.321Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.322Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-script-level’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.324Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-script-level’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.328Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.328Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-script-level’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.328Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.332Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-script-level’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.332Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.333Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.338Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.338Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-math-display’. Declaration dropped." on resource://gre-resources/mathml.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.338Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-canvas’. Ruleset ignored due to bad selector." on resource://gre/res/contenteditable.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.338Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-display-comboboxcontrol-frame’. Ruleset ignored due to bad selector." on resource://gre/res/contenteditable.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.338Z] 23:32:43 INFO - Ignored error "Error in parsing value for ‘display’. Declaration dropped." on resource://normandy/skin/shared/Heartbeat.css because of whitelist item {"sourceName":"/(skin\/shared\/Heartbeat|((?:res|gre-resources)\/(ua|html)))\.css$/i","errorMessage":"/Error in parsing value for .\bdisplay\b/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.341Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.343Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-inline-table’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.347Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-wrapper’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.348Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-row’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.349Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-column’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.350Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-column-group’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.352Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-row-group’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.354Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-table-cell’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.356Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-ruby’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.358Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-ruby-base’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.360Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-ruby-text’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.362Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-ruby-base-container’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.364Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-ruby-text-container’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.365Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-cell-content’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.367Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-block-inside-inline-wrapper’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.368Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-xul-anonymous-block’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.369Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-scrolled-content’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.369Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-viewport’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.372Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-viewport-scroll’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.376Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-column-set’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.378Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-column-set’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.380Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-column-span-wrapper’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.384Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-anonymous-flex-item’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.384Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-page-sequence’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.385Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-page’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.388Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-pagecontent’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.389Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-pagebreak’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.
-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.390Z] 23:32:43 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-browser-frame’. Ruleset ignored due to bad selector." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(contenteditable|EditorOverride|svg|forms|html|mathml|ua|pluginproblem)\.css$/i","errorMessage":"/Unknown pseudo-class.-moz-/i","isFromDevTools":false,"used":true}
[task 2019-05-17T23:32:43.391Z] 23:32:43 INFO - Ignored error "Unknown property ‘-moz-top-layer’. Declaration dropped." on resource://gre-resources/ua.css because of whitelist item {"sourceName":"/\b(html|mathml|ua)\.css$/i","errorMessage":"/Unknown property.
-moz-/i","isFromDevTools":false,"used":true}

Flags: needinfo?(rob)

There was a typo - "messsage" with triple "s". It wasn't obvious since the error message bar isn't used anywhere yet. After fixing the typo, I confirmed that all icons of the message bar looks as expected, and that the test passes.

I'll reland.

Flags: needinfo?(rob)
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/2519b62544a9
Support dark theme at HTML about:addons r=jaws
https://hg.mozilla.org/integration/autoland/rev/5dd4697aa1a1
Update <message-bar> to fully match Photon's style r=jaws
https://hg.mozilla.org/integration/autoland/rev/5142d8acf5e7
Support dark theme for radio input at abuse reports r=jaws
Depends on: 1553448
Regressions: 1553448
No longer depends on: 1553448
Depends on: 1553534
No longer depends on: 1552780
Regressions: 1552780
Depends on: 1555371

This issue is verified as fixed on Firefox 69.0a1 (20190529215251) and 68.0b6 (20190529145824) under Win 7 64-bit and Mac OS X 10.14.1.

The regressions caused by this bug were fixed and verified.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.