Perma tier2 dom/credentialmanagement/tests/mochitest/test_credman_iframes.html - mozrunner-startup | application crashed [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError_t, mozilla::WebAuthnTokenManager

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
critical
RESOLVED FIXED
Last month
15 days ago

People

(Reporter: intermittent-bug-filer, Assigned: jcj)

Tracking

(Regression, {crash, intermittent-failure, regression})

unspecified
mozilla68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed)

Details

(Whiteboard: [stockwell fixed:patch], crash signature)

Attachments

(3 attachments)

Reporter

Description

Last month
treeherder

Filed by: aciure [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=246211475&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/VGgdHe4RTEqxlAWpCTETxg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-13T22:05:03.461Z] 22:05:03 INFO - 1725 INFO TEST-START | dom/credentialmanagement/tests/mochitest/test_credman_iframes.html
[task 2019-05-13T22:05:03.461Z] 22:05:03 INFO - wait for org.mozilla.geckoview.test complete; top activity=com.android.launcher3
[task 2019-05-13T22:05:03.564Z] 22:05:03 INFO - remoteautomation.py | Application ran for: 0:00:13.344955
[task 2019-05-13T22:05:03.993Z] 22:05:03 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/GTjGxa3eSkS1mc4yN8RAAA/artifacts/public/build/target.crashreporter-symbols.zip
[task 2019-05-13T22:05:07.109Z] 22:05:07 INFO - mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpa3idUw/087bc35a-d48a-6e57-407c-fb5aff86c30f.dmp /tmp/tmpqAcOmC
[task 2019-05-13T22:05:10.917Z] 22:05:10 INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/087bc35a-d48a-6e57-407c-fb5aff86c30f.dmp
[task 2019-05-13T22:05:10.917Z] 22:05:10 INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/087bc35a-d48a-6e57-407c-fb5aff86c30f.extra
[task 2019-05-13T22:05:10.920Z] 22:05:10 WARNING - PROCESS-CRASH | dom/credentialmanagement/tests/mochitest/test_credman_iframes.html | application crashed [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError_t, mozilla::WebAuthnTokenManager, mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError>(_JNIEnv*, _jclass*, _jstring*)]
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - Crash dump filename: /tmp/tmpa3idUw/087bc35a-d48a-6e57-407c-fb5aff86c30f.dmp
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - Operating system: Android
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - 0.0.0 Linux 3.10.0+ #1 PREEMPT Thu Jan 5 00:46:30 UTC 2017 x86_64
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - CPU: amd64
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - family 6 model 2 stepping 3
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - 1 CPU
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - GPU: UNKNOWN
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - Crash reason: SIGSEGV /SEGV_MAPERR
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - Crash address: 0x0
[task 2019-05-13T22:05:10.920Z] 22:05:10 INFO - Process uptime: not available
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - Thread 11 (crashed)
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - 0 libxul.so!void mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError_t, mozilla::WebAuthnTokenManager, mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError>(_JNIEnv*, _jclass*, _jstring*) [Natives.h:edd79d65116b36e10075a90726bb657f93daf26c : 710 + 0x11]
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - rax = 0x00007a5d6b52993f rdx = 0x00007a5d6e3fcd68
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - rcx = 0x00007a5d6daf84a0 rbx = 0x0000000000001aee
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - rsi = 0x00007a5d6e3fcd64 rdi = 0x00007a5d7c5c00c0
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - rbp = 0x00007a5d6e3fcd20 rsp = 0x00007a5d6e3fcce0
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - r8 = 0x00007a5d6e3fd190 r9 = 0x00007a5d6eca5897
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - r10 = 0x00007a5d6eca589a r11 = 0x00007a5d6e3fcfb0
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - r12 = 0x00007a5d6e3fcf70 r13 = 0x00007a5d6e615c18
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - r14 = 0x00007a5d6e3fcd68 r15 = 0x00007a5d7c5c00c0
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - rip = 0x00007a5d696895b8
[task 2019-05-13T22:05:10.921Z] 22:05:10 INFO - Found by: given as instruction pointer in context
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - 1 base.odex + 0x767709
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rbx = 0x00007a5d85b1be00 rbp = 0x00007a5d6e3fcde8
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rsp = 0x00007a5d6e3fcd30 r12 = 0x00007a5d6e3fcf70
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - r13 = 0x00007a5d6e615c18 r14 = 0x00007a5d6e3fd190
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - r15 = 0x00007a5d6e3fd190 rip = 0x00007a5d6eed8709
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - Found by: call frame info
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - 2 0x7a5d6e3fd190
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rbp = 0x00007a5d6e3fd190 rsp = 0x00007a5d6e3fcdf8
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rip = 0x00007a5d6e3fd190
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - Found by: previous frame's frame pointer
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - 3 dalvik-LinearAlloc (deleted) + 0x9c18
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rbp = 0x00007a5d6e3fd190 rsp = 0x00007a5d6e3fce00
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rip = 0x00007a5d6e615c18
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - Found by: stack scanning
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - 4 base.odex + 0x534897
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rbp = 0x00007a5d6e3fd190 rsp = 0x00007a5d6e3fce18
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - rip = 0x00007a5d6eca5897
[task 2019-05-13T22:05:10.927Z] 22:05:10 INFO - Found by: stack scanning

Regressed by: 1551230
Summary: Intermittent dom/credentialmanagement/tests/mochitest/test_credman_iframes.html | application crashed [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError_t, mozilla::WebAuthnTokenManager, mozilla::jni:: → Perma tier2 dom/credentialmanagement/tests/mochitest/test_credman_iframes.html | application crashed [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError_t, mozilla::WebAuthnTokenManager, mozilla::jni::
Assignee

Updated

Last month
Assignee: nobody → jjones
Status: NEW → ASSIGNED
Component: DOM: Device Interfaces → DOM: Web Authentication
Priority: -- → P1
Comment hidden (Intermittent Failures Robot)
Summary: Perma tier2 dom/credentialmanagement/tests/mochitest/test_credman_iframes.html | application crashed [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError_t, mozilla::WebAuthnTokenManager, mozilla::jni:: → Perma tier2 dom/credentialmanagement/tests/mochitest/test_credman_iframes.html - mozrunner-startup | application crashed [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError_t, mozilla::WebAuthnTokenManager
See Also: → 1534033
Assignee

Comment 4

Last month

Yeah, we just need to update the tests to pref off the now-on Android code. I was out sick today, but I'll prepare a patch now.

Comment hidden (Intermittent Failures Robot)
Assignee

Comment 6

Last month

Patch is in bug 1551342. Assuming that works, I'll be duping this on that.

Assignee

Comment 7

Last month

The new Android functionality can conflict with the tests' expected behavior,
so it should be generally disabled, like the Rust module.

Assignee

Updated

Last month
See Also: → 1551837
Assignee

Updated

Last month
See Also: → 1551382

Comment 8

Last month
Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d9a6ddf12288
Update U2F, WebAuthn, and CredMan tests for Android r=keeler
Assignee

Comment 9

Last month

Discussion with :dvarga shows there's more to do here, another patch incoming.

Keywords: leave-open
Regressions: 1552076
Comment hidden (Intermittent Failures Robot)

Hi J.C. can you take a look at Bug 1552102 and Bug 1552076 too?

Flags: needinfo?(jjones)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
Assignee

Comment 14

Last month

https://phabricator.services.mozilla.com/D31366 isn't going to fix those crashes, but it helps yet more tests, so going to land it, too. Leaving this open still, for now.

Comment 15

Last month
Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/862aa43181c3
Fix conflicts w/ Android FIDO2 and Rust u2f-hid-rs r=keeler
Assignee

Comment 16

Last month

The mozilla::java::WebAuthnTokenManager asserts its return-to-C++ callbacks as
being run on the main Android UI thread, but since these methods are called
directly from the Fido2PendingIntent listeners, there's no guarantee of that.
We don't actually care what thread was tasked with returning us data, just that
it gets done, so let's not assert the thread here.

Assignee

Updated

Last month
Duplicate of this bug: 1552152
Crash Signature: , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError>(_JNIEnv*, _jclass*, _jstring*)] → , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError>(_JNIEnv*, _jclass*, _jstring*)] [@ mozilla::jni::NativeStub<T>::Wrap<T>]
Assignee

Updated

Last month
No longer regressions: 1552076
Duplicate of this bug: 1552076
Assignee

Updated

Last month
Duplicate of this bug: 1552102
See Also: → 1307868
Crash Signature: , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError>(_JNIEnv*, _jclass*, _jstring*)] [@ mozilla::jni::NativeStub<T>::Wrap<T>] → , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnMakeCredentialReturnError>(_JNIEnv*, _jclass*, _jstring*)] [@ mozilla::jni::NativeStub<T>::Wrap<T>] [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnT…
Assignee

Comment 20

Last month
Crash Signature: , _jstring*)] [@ mozilla::jni::NativeStub<T>::Wrap<T>] [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnGetAssertionReturnError_t, mozilla::WebAuthnTokenManager → , _jstring*)] [@ mozilla::jni::NativeStub<T>::Wrap<T>] [@ mozilla::jni::NativeStub<mozilla::java::WebAuthnTokenManager::WebAuthnGetAssertionReturnError_t, mozilla::WebAuthnTokenManager
Flags: needinfo?(jjones)

Comment 21

Last month
Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5fae8054799f
Don't assert the thread calling JNI WebAuthn functions r=snorp
Assignee

Updated

Last month
Duplicate of this bug: 1551382
Comment hidden (Intermittent Failures Robot)
Assignee

Updated

Last month
Duplicate of this bug: 1534033
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
Comment hidden (Intermittent Failures Robot)
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:patch
Whiteboard: [stockwell fixed:patch → [stockwell fixed:patch]
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 29

28 days ago

I believe this is resolved; the oranges from the last several days marked as this bug are not crashes, they all appear to be instead miscategorizations of a web platform test intermittent:

INFO - TEST-UNEXPECTED-FAIL | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad alg (42) - assert_throws: Expected bad parameters to fail function "function() { throw e }" threw object "UnknownError: The operation failed for an unknown transient reason" that is not a DOMException NotSupportedError: property "code" is equal to 0, expected 9

Status: ASSIGNED → RESOLVED
Closed: 28 days ago
Keywords: leave-open
Resolution: --- → FIXED

(In reply to J.C. Jones [:jcj] (he/him) from comment #29)

I believe this is resolved; the oranges from the last several days marked as this bug are not crashes, they all appear to be instead miscategorizations of a web platform test intermittent:

INFO - TEST-UNEXPECTED-FAIL | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad alg (42) - assert_throws: Expected bad parameters to fail function "function() { throw e }" threw object "UnknownError: The operation failed for an unknown transient reason" that is not a DOMException NotSupportedError: property "code" is equal to 0, expected 9

I reopened Bug 1551382, as it was marked a duplicate of this bug, and has the same failure that you mention here as not being related to this bug.

Assignee

Updated

27 days ago
Duplicate of this bug: 1551837
Assignee

Updated

27 days ago
Duplicate of this bug: 1552521
Crash Signature: , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnGetAssertionReturnError>(_JNIEnv*, _jclass*, _jstring*)] → , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnGetAssertionReturnError>(_JNIEnv*, _jclass*, _jstring*)] [@ (anonymous namespace)::ParentImpl::AssertIsOnBackgroundThread()]
Status: RESOLVED → REOPENED
Crash Signature: , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnGetAssertionReturnError>(_JNIEnv*, _jclass*, _jstring*)] [@ (anonymous namespace)::ParentImpl::AssertIsOnBackgroundThread()] → , mozilla::jni::Args<mozilla::jni::StringParam const&> >::Wrap<&mozilla::WebAuthnTokenManager::WebAuthnGetAssertionReturnError>(_JNIEnv*, _jclass*, _jstring*)] [@ (anonymous namespace)::ParentImpl::AssertIsOnBackgroundThread()]
Resolution: FIXED → ---
Flags: needinfo?(jjones)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 35

21 days ago

No instances in the last 6 days... and the last erroring patchset didn't have https://hg.mozilla.org/mozilla-central/rev/5fae8054799f
in it. I think this is still closed.

Status: REOPENED → RESOLVED
Closed: 28 days ago21 days ago
Flags: needinfo?(jjones)
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.