Closed Bug 1551382 Opened 4 months ago Closed 4 months ago

Perma tier2 /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad alg (42) - assert_throws: Expected bad parameters to fail function "function() { throw e }" threw object "UnknownError: The operation failed

Categories

(Core :: DOM: Web Authentication, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jcj)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=246221805&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/Sg1v4OTDTJe9owLKnYvikA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-13T23:11:10.340Z] 23:11:10 INFO - TEST-START | /webauthn/createcredential-pubkeycredparams.https.html
[task 2019-05-13T23:11:10.341Z] 23:11:10 INFO - Closing window 24
[task 2019-05-13T23:11:10.624Z] 23:11:10 INFO -
[task 2019-05-13T23:11:10.624Z] 23:11:10 INFO - TEST-PASS | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: pubKeyCredParams is undefined
[task 2019-05-13T23:11:10.624Z] 23:11:10 INFO - TEST-PASS | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: pubKeyCredParams is string
[task 2019-05-13T23:11:10.624Z] 23:11:10 INFO - TEST-PASS | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: pubKeyCredParams is null
[task 2019-05-13T23:11:10.625Z] 23:11:10 INFO - TEST-PASS | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad type ("something-else")
[task 2019-05-13T23:11:10.625Z] 23:11:10 INFO - TEST-PASS | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad type ("")
[task 2019-05-13T23:11:10.625Z] 23:11:10 INFO - TEST-PASS | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad type (null)
[task 2019-05-13T23:11:10.625Z] 23:11:10 INFO - TEST-PASS | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad type (empty object)
[task 2019-05-13T23:11:10.625Z] 23:11:10 INFO - TEST-UNEXPECTED-FAIL | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad alg (42) - assert_throws: Expected bad parameters to fail function "function() { throw e }" threw object "UnknownError: The operation failed for an unknown transient reason" that is not a DOMException NotSupportedError: property "code" is equal to 0, expected 9
[task 2019-05-13T23:11:10.626Z] 23:11:10 INFO -
[task 2019-05-13T23:11:10.626Z] 23:11:10 INFO - TEST-UNEXPECTED-FAIL | /webauthn/createcredential-pubkeycredparams.https.html | Bad pubKeyCredParams: first param has bad alg (0) - assert_throws: Expected bad parameters to fail function "function() { throw e }" threw object "UnknownError: The operation failed for an unknown transient reason" that is not a DOMException NotSupportedError: property "code" is equal to 0, expected 9
[task 2019-05-13T23:11:10.843Z] 23:11:10 INFO - TEST-OK | /webauthn/createcredential-pubkeycredparams.https.html | took 503ms
[task 2019-05-13T23:11:11.482Z] 23:11:11 INFO - Closing logging queue
[task 2019-05-13T23:11:11.482Z] 23:11:11 INFO - queue closed
[task 2019-05-13T23:11:11.497Z] 23:11:11 INFO - Setting up ssl
[task 2019-05-13T23:11:11.513Z] 23:11:11 INFO - certutil |
[task 2019-05-13T23:11:11.528Z] 23:11:11 INFO - certutil |
[task 2019-05-13T23:11:11.536Z] 23:11:11 INFO - certutil |
[task 2019-05-13T23:11:11.536Z] 23:11:11 INFO - Certificate Nickname Trust Attributes
[task 2019-05-13T23:11:11.536Z] 23:11:11 INFO - SSL,S/MIME,JAR/XPI
[task 2019-05-13T23:11:11.536Z] 23:11:11 INFO -
[task 2019-05-13T23:11:11.536Z] 23:11:11 INFO - web-platform-tests CT,,
[task 2019-05-13T23:11:11.536Z] 23:11:11 INFO -
[task 2019-05-13T23:11:13.260Z] 23:11:13 INFO - adb Granting important runtime permissions to org.mozilla.fennec_aurora
[task 2019-05-13T23:11:14.507Z] 23:11:14 INFO - adb launch_application: am start -W -n org.mozilla.fennec_aurora/org.mozilla.gecko.BrowserApp -a android.intent.action.VIEW --es env9 MOZ_PROCESS_LOG=/tmp/tmpHhPVfapidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env10 R_LOG_LEVEL=6
[task 2019-05-13T23:11:15.944Z] 23:11:15 INFO - Starting runner

Flags: needinfo?(jjones)
Regressed by: 1551230

Ah, ok, we're going to have to disable the Android-enablement pref for the mochitests.

Assignee: nobody → jjones
Status: NEW → ASSIGNED
Flags: needinfo?(jjones)
Priority: P5 → P2

Patch for this in Bug 1551342. I'll be duping this on that when it resolves.

See Also: → 1551342

I'm pretty sure this is fixed in Bug 1551342.

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1551342
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Thanks for reopening. I'll have to dig into this WPT failure next week. Keeping this assigned to me.

The solution here will be disabling this test on Android.

Actually, correction, this can be fixed with a pref fix. Attempting on try.

Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aaea71be6b53
Correct WebAuthn WPT prefs (fix Android) r=jgraham
Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1557201
You need to log in before you can comment on or make changes to this bug.