Closed Bug 1551442 Opened 1 year ago Closed 1 year ago

[ESR builds][Tablet] Make default browser option not displayed on top of the Settings Menu

Categories

(Firefox for Android :: Settings and Preferences, defect)

Firefox 68
All
Android
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox68 --- affected

People

(Reporter: stefan.deiac, Assigned: petru)

References

Details

Environment:
Device:

  • Lenovo Yoga Tablet 2 (Android 4.4.2) - x86;
  • Xiaomi Mi Pad 2 (Android 5.1) - x86-64;
  • Samsung Galaxy Tab S3 (Android 8.0) - AArch64.

Build: Nightly ESR 68.0a1 (2019-05-07) and Beta ESR 68.0b1;

Prerequisites: Nightly(or Beta) is not set as the default browser.

Steps to reproduce:

  1. Launch Firefox and go to Settings;
  2. Observe the position for - "Make Nightly" your default browser.

Expected result:
"Make Nightly your default browser" option is placed below "Sign-in".

Actual result:
"Make Nightly your default browser" option is placed below "Clear private data" and above "Mozilla".

Notes:

  • Not reproducible on the official build of Nightly.
Blocks: ESR-Fennec

I see this is the exact same behavior as the one before bug 1547929
Maybe the patch of that isn't part of ESR ?

Decompiled the ESR Nightly and saw that it does not contain the changes from bug 1547929. So it is normal to still be affected by that bug.
NI-ing Ryan to confirm that the patches from 1547929 are not included in the current ESR builds under test.

Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Flags: needinfo?(ryanvm)

Yeah, these builds would have predated that bug landing. Johan's patches have bitrotted since his Try push, so I can't provide updated builds at the moment, but I'll do so after he returns from PTO.

Flags: needinfo?(ryanvm)

Thanks Ryan!
Based on this will close this as INVALID.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.