Closed Bug 1551458 Opened 7 months ago Closed 6 months ago

Back button won't go back in history (Pixel 3 XL(Android 9))

Categories

(Firefox for Android :: General, defect, P1)

All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox66 --- wontfix
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- verified
firefox69 --- verified

People

(Reporter: JanH, Assigned: andrei.a.lazar)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [bcs:p1])

Attachments

(1 file)

For some reason the fix from bug 1252310 doesn't seem to work on a Pixel 3 XL(Android 9), i.e. after pressing Enter in the URL bar, the next key press (e.g. a back button press) is ignored.

Does this issue also affect GeckoView and Fenix on the Pixel 3 XL?

Whiteboard: [bcs:p1] → [bcs:p1] [geckoview]?

Andrei, can you reproduce this Back button bug in Fenix or the Reference Browser? Or does this bug only affect Fennec?

Flags: needinfo?(andrei.joltan)

Hi Chris, the issue can't be reproduced neither in Fenix nor in the Reference Browser.
I've checked the latest Nighlty build and the issue still persists.

Many thanks,
Andrei

Flags: needinfo?(andrei.joltan)

(In reply to andrei.joltan from comment #3)

Hi Chris, the issue can't be reproduced neither in Fenix nor in the Reference Browser.
I've checked the latest Nighlty build and the issue still persists.

Thanks for checking, Andrei. In that case, I'll close this bug as WORKSFORME.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME

It's still a legitimate Fennec bug, though, isn't it?

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Adding 68=affected and removing [geckoview] whiteboard tag because this is a Fennec bug.

Whiteboard: [bcs:p1] [geckoview]? → [bcs:p1]

:JanH, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(jh+bugzilla)

Possibly based on the parent bug, although not 100% sure, since I cannot test this myself.

Flags: needinfo?(jh+bugzilla)
Regressed by: 1278581

Sorina: I think you have a Pixel 3 XL - are you (or someone else) able to reproduce this issue?

Flags: needinfo?(sorina.florean)

According to bug 1252310 comment 27 it was somebody from Softvision who noticed this in the first place - what it needs is ideally somebody who can actively debug this.

Removing the ni. Petru or Andrei could likely help - but they would need the device.

Flags: needinfo?(sorina.florean)

Managed to reproduce this on both Pixel 3 (Android Q) and Pixel 3XL (Android 9)
Entering an URL and accessing a page will result in the first back button press being ignored.
By opening an external link in a new tab the issue cannot be reproduced.

Assignee: nobody → andrei.a.lazar

Created an exception in the key event suppression mechanism for the back button KEYCODE.

Keywords: checkin-needed

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f0a2c42d0ef7
Back button won't go back in history (Pixel 3 XL(Android 9)) r=VladBaicu

Keywords: checkin-needed
Status: REOPENED → RESOLVED
Closed: 7 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

We'll want to uplift this fix to Fennec 68 Beta (or Fennec 68.1 ESR, if Relman doesn't want to take more 68 Beta uplifts).

Comment 3 says the issue can't be reproduced in Fenix or in the Reference Browser.

Please nominate this for Beta uplift when you get a chance.

Flags: needinfo?(andrei.a.lazar)
Flags: needinfo?(andrei.a.lazar) → qe-verify?

Hi verified as fixed on Nightly 69.0a1 (18/06) using a Google Pixel 3XL (Android 9) and a Samsung Galaxy S6 (Android 6.0.1).

Status: RESOLVED → VERIFIED
Flags: qe-verify?

Comment on attachment 9070242 [details]
Bug 1551458 Back button won't go back in history (Pixel 3 XL(Android 9)) r=JanH

Beta/Release Uplift Approval Request

  • User impact if declined: One of the most common behaviors will be broken.
  • Is this code covered by automated tests?: Unknown
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): This was tested under a lot of scenarios and conditions and the change is small.
  • String changes made/needed: -
Attachment #9070242 - Flags: approval-mozilla-beta?

Can you explain a bit more what this does and why?

Flags: needinfo?(andrei.a.lazar)

Hi Stefan, how critical is this fix? Should this be a MVP blocker?

Flags: needinfo?(sarentz)

Hello @Ritu please note that initially this was the main issue and after it was fixed, I found that on google pixel there is still a problem on imdb.com. but on any websites too.
At Comment 3 you can see that Andi couldn't reproduce this issue on Fenix and RB from that time.
Now we couldn't reproduce this issue on Google Pixel and everything is working as expected. Confirmed in Comment 18.

Thanks,
Andrei

This patch introduces an exception for the back key code event which was being suppressed under certain scenarios. The fix has been tested by the QA and everything works as intended now. Since we have issues with the buggy behavior of the back button, I think it is safe to say that quite a significant number of users may be impacted. However, I cannot provide a clear answer if this is an MVP blocker or not.

Flags: needinfo?(andrei.a.lazar)

[Tracking Requested - why for this release]:

We will want to uplift this Fennec fix to the ESR 68 branch for the Fennec 68.1 release. I don't know the details of this bug well enough to say whether we want to take it for a late fix in Fennec 68.0 Beta or a 68.0.1 dot release.

(In reply to Ritu Kothari (:ritu) from comment #21)

Hi Stefan, how critical is this fix? Should this be a MVP blocker?

This is a Fennec bug fix, so it is not a Fenix MVP blocker.

Flags: needinfo?(sarentz)

Comment on attachment 9070242 [details]
Bug 1551458 Back button won't go back in history (Pixel 3 XL(Android 9)) r=JanH

I wish I understood what's special about that button and those devices... I'll take it for the next beta though.

Attachment #9070242 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi, verified as fixed on 68.0b14 using a Google Pixel 3XL (Android 9)

You need to log in before you can comment on or make changes to this bug.