border-collapse:collapse and printing

VERIFIED FIXED

Status

()

VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: liviu, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

21.13 KB, text/html
Details
(Reporter)

Description

17 years ago
When I print or view in print preview a table with style
border-collapse:collapse it has borders drawn only on the first page.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<style>
table {
   border-collapse:collapse;
}
</style>
</head>
<body>
<table border="1">
<tr>
   <td>mumu</td>
   <td>mumu</td>
   <td>mumu</td>
</tr>
<!-- enough rows to have more pages -->
</table>
</body>
</html>

Comment 1

17 years ago
Chris?
Assignee: rods → karnaze
(Reporter)

Comment 3

16 years ago
The testcase is not valid.
It needs a table with, say, 100 rows.
When I __print__ (or print preview) it the borders are drawn only on first
_printed_ page.

Comment 4

16 years ago
Created attachment 97404 [details]
testcase 2

still WORKSFORME
reporter, please check if you have any other styling that interferes
with border-collapse: collapse
Attachment #97372 - Attachment is obsolete: true

Comment 5

16 years ago
reporter reported in an e-mail:
> sorry for being late with my reply...
> works for me too (v1.1b)
> I don't remember what versions I had when I reported (stupid me).  OSes 
> were W2000, RedHat 7.2 and SuSE 8.0.
> Anyway it seems that it was worked out in the meantime.
> Thank you.
> Liviu
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 6

16 years ago
verified per comment.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.