Closed Bug 1551563 Opened 3 months ago Closed 3 months ago

"Manage shortcuts" at about:addons shows hidden extensions/built-in search engines

Categories

(Toolkit :: Add-ons Manager, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox67 --- unaffected
firefox68 --- verified
firefox69 --- verified

People

(Reporter: robwu, Assigned: robwu)

References

Details

(Whiteboard: [bugday-20190529] )

Attachments

(4 files, 1 obsolete file)

STR:

  1. Visit about:addons.
  2. Click on the Extensions tab.
  3. Click on the gears and then click on the "Manage Extension Shortcuts" menu item.

Expected:

  • Should only show items that also appear in the extension list.
  • Should not show hidden extensions, except if they support keyboard shortcuts.

Actual:

  • Shows hidden extensions, even if they do not support shortcuts:

The following extensions do not have shortcuts:

  • Amazon.com
  • Bing
  • DuckDuckGo
  • eBay
  • Google
  • hotfix-update-xpi-intermediate
  • Twitter
  • Wikipedia (en)

The hidden/built-in search engines are from bug 1486820.

Not a big deal, but should be addressed in the html version. Mark, can you add this in to your list?

Flags: needinfo?(mstriemer)
Priority: -- → P2

I'll take this, to prevent the lot of built-in search extensions from appearing in 68.

Assignee: nobody → rob
Status: NEW → ASSIGNED
Flags: needinfo?(mstriemer)

In bug 1522757, a new test was added to verify that extensions without
shortcuts were hidden in the shortcut view, and shown in a list of
extensions without shortcuts.

The test was inserted in an existing test that did not have anything to
do with the change. In the next patch, I am going to add similar tests,
so the test logic was moved to a separate file.

See Also: → 1553416
Attachment #9066051 - Attachment is obsolete: true
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/6e43b0f4322b
Move shortcut test to own file r=mstriemer,mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/9a811a4d134d
Hide hidden/builtin extensions in shortcuts view r=mstriemer,mixedpuppy,kmag
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9066053 [details]
Bug 1551563 - Hide hidden/builtin extensions in shortcuts view

Beta/Release Uplift Approval Request

  • User impact if declined: The "Manage shortcuts" view contains a list of built-in search engines, starting from Firefox 68 because of bug 1486820 .
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: comment 0 has STR if QE wants to verify.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): 1 line change in UI code, plus tests.
  • String changes made/needed:
Attachment #9066053 - Flags: approval-mozilla-beta?
Attachment #9066052 - Flags: approval-mozilla-beta?

Does this address both the old and new about:addons?

Flags: needinfo?(rob)

(In reply to Julien Cristau [:jcristau] from comment #9)

Does this address both the old and new about:addons?

Yes it does. The "Manage shortcuts" view is written in HTML already (not XUL), and used by both the old and new about:addons.

Flags: needinfo?(rob)

I have reproduced this bug with Nightly 68.0a1 (2019-05-14) on Windows 7, 64 Bit. The fix of this bus is verified with latest Nightly!

Build ID : 20190602221035
User Agent : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Whiteboard: [bugday-20190529]

Comment on attachment 9066053 [details]
Bug 1551563 - Hide hidden/builtin extensions in shortcuts view

addons manager fix for 68.0b7

Attachment #9066053 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9066052 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified the fix on the latest versions of Nightly (69.0a1 / 20190604214415) and Beta (68.0b7 / 20190603181408) under Windows 10 Pro 64-bit and macOS High Sierra 10.13.6.

The fix appears to be valid as when accessing the "Manage Extension Shortcuts" page from the gears menu, all installed extensions which support shortcuts are properly displayed and all installed extensions which do not support shortcuts are listed below, under the ‘The following extensions do not have shortcuts:‘ section. Any uninstalled extensions lacking shortcut support will no longer be displayed under the above mentioned section as in previous builds.

However, there is a slight difference between the Nightly and the Beta versions, as on Nightly, a ‘Firefox Screenshots’ extension with shortcut support is present among the installed extensions which support shortcuts. Please see the attached screenshots for further details.

Can you please confirm this is the correct behavior before validating the fix and marking the issue as Verified Fixed?

Flags: needinfo?(rob)

(In reply to Alex Cornestean from comment #14)

However, there is a slight difference between the Nightly and the Beta versions, as on Nightly, a ‘Firefox Screenshots’ extension with shortcut support is present among the installed extensions which support shortcuts. Please see the attached screenshots for further details.

Can you please confirm this is the correct behavior before validating the fix and marking the issue as Verified Fixed?

This is as expected. This bug has a "see also" to bug 1553416, which adds Screenshots to the "Manage shortcuts" view.
Although the patch for that bug is simple, I did not request an uplift because it was not a regression (unlike this bug).

Status: RESOLVED → VERIFIED
Flags: needinfo?(rob)
You need to log in before you can comment on or make changes to this bug.