Closed Bug 1551601 Opened 5 months ago Closed 4 months ago

Perform cross-process switch before processing cached redirect

Categories

(Core :: Networking, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Fission Milestone M4
Tracking Status
firefox68 + disabled
firefox69 + fixed

People

(Reporter: valentin, Assigned: valentin)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file, 2 obsolete files)

Processing the cached redirect before processing the cached redirect is not only wrong, but it also interacts badly with the service worker interception.

Attachment #9065005 - Attachment is obsolete: true

Valentin, is this intended to be uplifted to 68 beta? Please add approval request/flag as appropriate. Thanks!

Flags: needinfo?(valentin.gosu)

(In reply to Nhi Nguyen (:nhi) from comment #3)

Valentin, is this intended to be uplifted to 68 beta? Please add approval request/flag as appropriate. Thanks!

Uplift approval is requested after the patch gets reviewed and usually after it lands on central.

Flags: needinfo?(valentin.gosu)
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ecceef291b89
Do process switch _before_ processing cached redirect r=mayhemer
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1555034

HTTPResponseProcessSelection was turned off in beta by bug 1554217

I backed this out in bug 1555966 per Valentin's request to fix the regressions it caused.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla69 → ---
Fission Milestone: --- → M4
Blocks: 1552012
Blocks: 1556377
Blocks: 1561706
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2719ba46ac12
When performing a cross process redirect update the loadInfo to have the correct browsingContext r=nika
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1582b3ffe712
When performing a cross process redirect update the loadInfo to have the correct browsingContext r=nika
Status: REOPENED → RESOLVED
Closed: 5 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Flags: needinfo?(valentin.gosu)
Blocks: 1562223
Attachment #9065026 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.